Plex Media server once again not working

Hi there,
on my web radio I found Plex Media server not working anymore. When loggin in the web app I found this new error. „Unable to connect MCH securley“ Waht is this now? What can I do? I tried to disable plex a couple of times and reabled it. In MCH-App it shows that it is installed but not on DLNA devices. Theres no way to configure anything


One of the biggest mistake Western Digital made was to advertise Plex support on the My Cloud Home. Any simple free DLNA server could have worked better on the MCH without generating so many errors as Plex. There are hundreds of ways that Plex can’t connect securely.

2 Likes

Apr 2024 and I have this exact same problem. What was it? Service provider? or is it Plex on MCH the issue once more?

Of course I have tried many times enabling it for many days now, but I never disabled it. It is very frustrating.

So it’s been weeks now and no body nowhere to help.

Seems no body is responsible for the issue.

I have the same issue…

Did you find a solution?

TY

not yet

okay, thank you

Definitely MCH is a great product :sweat_smile: :joy:

Plex is incompatible with WD MyCloud Home (MCH). It will simply not talk to the MCH. I enabled it via my desktop Mac (which will not connect to MCH). Unable to enable it on mobile platforms (IPhone and iPad), but instead configured it.
Plex recognises MCH but I get the same error message as above.

My WiiM streamer does not recognise (MCH) so my guessing is that MCH is at fault. I purchased it from Amazon a few days ago and I’m going to return it as faulty