PLEASE help ! cloud drops TV connection


I’ve been playing around with my cloud for weeks now.  I use it purely for watching films on my LG tv via DLNA.  It still loses connection - I have gradually done the following and am now going nuts !

set all IP addresses outside range of router’s dhcp (via reserved IP address in router)

turned off NIC reset in Twonky

turned off all other media devices in twonky (i.e., the missus’ ipad and phones etc)

TV appears twice in Twonky (as two devices recognised) - I turned off the redundant one in Twonky

upgraded to gigabit ethernet connection - using powerlines

turned Twonky’s rescan to zero

turned off the cloud’s sleep setting

it still drops connections at random times  when watching films.  the cloud is still connected as i just select DLNA via input on tv and then resume viewing - someone must have cracked this nut by now !  anymore advice please… :slight_smile:


I am not that familier with using powerline adapters but my understanding is they are slow. you may have a gigabit port on the adapter but please chect actual transfer speed

thanks for the reply.  transfer speeds are fine and would still be better than 100mbps lan or wi-fi.  they are the latest available tplink devices.  i am wondering if it has something to do with the tv’s dmr and the fact it shows up with two IP addresses on twonky media devices (although i have managed to now set them to the same address by using IP reservation in my router setttings).  if i set the tv as a static of the reserved IP address, i can connect to the internet but no DLNA device is registered…

anyone with suggestions - be great to solve this issue for others as well??  it must be some sort of IP refresh issue or maybe a cache issue?? 

just a thought - can i plug my cloud straight into the TV via ethernet to see if it is TV or network related?


you may be able to connect them directly however since you reserved an IP instead of setting a static IP it may not keep the IP when you boot it off the router

can you move the router, TV & mycloud together for testing?

Good point - once off the router it will probably loose the IP.  Not tried to set static on cloud as yet, and i see on the forums issues with bricking the device. 

what do you mean by move them all together? 

if i do attempt direct connection to TV (to eliminate my network as being the issue) how do i configure the IP

TV will ask for -

IP address (static address given to cloud?)

Gateway (not required?)

DNS? do i need to enter a DNS address

I’ve just ordered a long 5e cable for direct connection to the TV to see if powerline is the issue, but i can transfer large folders from my book via laptop real quick using the adapters.

thanks for your input - if i can solve this it might help many others.  or at least save them going through all the same steps!

just place the router, TV & mycloud close together and plug the TV & mycloud into the router. it does not need an Internet connection for this.

also setting a static IP will no brick the mycloud. you can do the 4 or 40 second reset to restore to DHCP settings

se manual for details but I believe the 4 second resets the admin passowrd and IP to DHCP and not much else. the 40 second deletes users and resets everything except leaving the shares and data in place

many thanks larryg - on the subject of the OP and troubleshooting:

powerline - will connect via direct ethernet cable to check

router/network - will connect cloud straigt to TV to check

TV - any troubleshooting suggestions to see if TV causes the drops (I never had any problems using flash/external HDD)?

Twonky - any suggestions to check if twonky causes the drops?

once isolated, i will know where to focus my efforts. 

TV/Twonky issue can be difficult to isolate.

I have a dish hopper it it doesn’t play well with the mycloud. the hopper works well with Plex on my PC, my LG TV work well with the Mycloud & Plex. I have no idea whos faul it is or if it is general DLNA issues. this is not dropping connections though is why i am trying to verify the network 1st.

I have an LG as well.  everything worked fine for the first few days, then the connection drops just started randomly.  Have just got a bright box 2 so i think i will reset the cloud and fire it all up fresh with the new router.  will report back.  thanks for your input so far.

not pointing any fingers at this stage, but my instinct tells me it lies with twonky just because it seems dlna related

OK - so i hard wired the connection last night straight to the TV, and it played for 2 hours with no drops (cowboys vs aliens - not too bad a film as it goes).  normally got no further than 30 mins.

anyone having drop issues streaming to TV over powerlines might want to try this troubleshooter - which is probably obbvious to most though - looking at you larryg :slight_smile:

i wonder if updating my powerline adapters from 100mbps to gig ports was an issue - about that time it started dropping…pushing bigger packets perhaps?

will see if the stability continues

a lot of things can impact powerline communications, if not it would probably be much more widespread since it is so easy.

I would suggest direct CAT 5e or 6 connections if possiable, if not a wireless router is the next choice, some have much greater range then others and there are range extenders although I was not satisfied with the one I bought.

if you want to continue with the powerline you could try changing which outlet you plug them into, try 1 end at a time and see if it is better or worse. there is probably some combinations that would work well however you may not find the proper combination in the locations you need

in the US at least most houses are wired where you efectivly have 2 seperate wires in your house that go back to the power company transformer. If you can find 2 outlets on the same side of the powerline it should help. there is no easy way to determine which it will be without opening the panel and tracing circuts which I do not suggest unless you are very comforable with panels as it can easily be deadly if you make a mistake.

1 Like

watched another film straight through last night with no drops.  so feel I can put this down as solved in so far as the powerline adapters causing the drops.  i live in the UK so we usually have a more stable wiring system for PLA’s.   only rewired the house two years ago - we’ve got three fridges on the circuits (one for beer of course).  i feel it could be their thermostats kicking in, which might explain the randomness of the drops.  going to try your suggestion of different sockets, and for what they cost i will stick some ferrites on every power cable i can find.  don’t think the missus will like me tearing up the new carpet and floorboards again

otherwise, i have to say that my My Cloud works perfectly and transfers files really quick.  I will probably see smoke coming out of it tonight…