PASSPORT WD 2TB installation problems

Trying to install a 2TB passport to back up my computer.
It went through the installation, said it was successfully installed, and gave 3 tabs
1 Back up files and WD backup
2 Set security
3 Drive utilities
If I select options 2 or 3 they work fine.
If I select Option 1 absolutely nothing happens

I manually ran the WD backup exe for Windows (Im on Windows 7 - yes some people still are!) from the Passport directory, which again seemed to install ok, and said ‘Click back up files to set up your first back up’, which I did…but that just took me to a second screen to select storage device or cloud service BUT it just says ‘NO back up targets found’, RESCAN, but even pressing rescan it can’t find anything and just comes back to the same statement.
Please can someone tell me what I’m doing wrong?
I found a partial post on here from ages ago, with possibly the same problem, but the solution wasn’t posted.
can anyone help please? I’ve emailed WD support and had no reply in 2 days.
I don’t know if I should take it back to the shop faulty???


What OS are you using?
Is the drive seen on the computer?

Hi Alison I’m having the exact same issue but I am also unable to run the other two choices and cannot find any links on my PC to the applications even after installing them? Using Win 7 64bit

Sorry to hear that Bill. Perhaps hamlet will have a solution for us both!

I’m using Windows 7 home addition and yes my computer finds my passport no problem.

One solution I think I’ve found is to use Windows back up from the control panel. It’s just a shame I can’t use the software that comes with the passport. Any ideas to get it working would be greatly appreciated. Thanks


Have you tried using WD Smartware?

Is that an application? Is it in Downloads?

I’ve installed WD Smartware but when I run it my WD drive still does not show as a target? My PC does recognize it though.

Well a Tech support person from WDC emailed me and we have tried several remedies suggested but no fix for the problem? Also Tech Support tells me that WD Smartware is not compatible with the drive I bought but the WD Backup software is. So I uninstalled Smartware and retried WD Backup but still not recognized as a target. Then I reformatted the WD 2T using diskmgmt.msc as per suggestions and still same issue? Very frustrated by this process and not happy at all. I have been a customer of WDC and have never had this many problems before.
Bill Denson

I surrender and after days of trying to resolve my issues with the WD Backup software I am going to return my drive for a refund and try Seagate! Don’t know if my experience will be any better but that is the direction I’m headed.

Bill I haven’t managed to get anywhere with their software either, BUT what I have done is 2 things. One is I have manually copied/backed up my files by copying and pasting, but I also used my Windows BACKUP/RESTORE system, to do a complete back up to the Passport. So I’m ok with that. Not sure they will refund, and they’ll say it’s our systems that are the problem - but then it shouldn’t say it’s ok for Win 7 should it if that’s the case as it clearly doesn’t work. :weary:

I looked at your case, and based on the knowledge base article the agent gave you, you may need to “allow” WD Backup to work with your anti-virus software. There should be an option in your anti-virus software that “allows” programs to work that have been blocked.

Also, I would make sure you’ve downloaded the latest version of WD Backup. That’s if you still want to try it.