Passport essential just stopped working

I have no idea what happened. A day before I was using my harddisk without a problem but today for now reason my computer stopped reading the harddisk. Strange thing is it reads the WD Smartware drive on the harddisk but not the other one. I’ve tried everything and it seems like it maybe me locked?. I’m not sure because I’ve never put a password on it before . When I try to run the WD Smartware software it goes straight to the enter password screen. Plz can anyone help me with this . I have 400Gb of info on this harddisk and i dont want to format it

same thing is happening to me…

any help please

Try with passwords in Lower Case or Capitals, THERES NO WAY TO UNLOCK THE HD without the Password, If you Dont Get the drive to be Unlock All data Will be GONE!!

last step remaining Will be to erase the unit which deletes EVERYTHING…

Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue. This may help someone else.

1 Like