OS5 Plex issue

If you’re going to update to OS5 (which I now regret I did on one of my 2 devices) ssh into the NAS and backup your Plex folders. The update wont delete your app data and folders but when you update the Plex app, things can break due to leaving old files and the downloads on the Plex page arent for OS5. Those will be posted soon hopefully.

This is the proper update: https://downloads.plex.tv/plex-media-server-new/

If you cant access Plex after the update then turn off Plex, uninstall it in the WD app section, ssh in again and delete both Plex folders. Now install the above linked Plex install, open the config page then turn off Plex again.

Now load your backup folders and files. You will need to rebuild your libraries but will retain your settings.

I wont be upgrading my main NAS to OS5 for a LONG time.

Although the Plex version on their store is old, mine worked out of the box. I have a ex2 ultra

The initial version will work but if you update you must use the OS5 version that isn’t live on the downloads page yet. Some people are saying even that didn’t work and they’ve had to delete everything.

Now another user is saying ssh won’t login on 5 so he can’t remove the old folders that should have been deleted.

on my PR4100 I updated the OS, and then Plex from Store. It was not a too old version, opened the Plex dashboard downloaded the latest version of the server, and updated it manually on the NAS App menu.
Worked fine.

You installed



I did the exactly same steps as you.

@TylerV76 my ssh is working too. Same sshd user

Thats not the one that populated for myself and others when doing it through Plex. That version isn’t live yet so as far as I’m aware its only available through the thread on Plex Forums. Unless they’ve made it live due to the issues. The one we got was 3483 and it broke everything.

Yeah the OS5 version still isn’t live on Plex’s site so not sure how you ended up with it without downloading from the above link.

You’re right, it’s not available on their website yet, only if you install Plex from WD store, then Plex dashboard will give you the correct link.

It gave me an old copy then when I tried to update to the current version it broke. The wd store is giving 3508_OS5 now? Plex is saying its still giving an old version.

I have PlexPass, maybe this is why…

I don’t remember what was the version available on WD store. I just know that after updating all the apps were gone and Plex was available as “Reinstall”. Once installed and running, Plex dashboard suggested that there was an update available and the link was to the OS5 version.

maybe, because Plex pass gives you access to beta. I’m a free user, so I went through the same manual steps you did.

but check the link on the top message

I have Plex Pass also

If anyones having issues look there.

Decided to do the update against my better judgement on my 2nd NAS and this time the update gutted my Plex folders. This update is not ready yet.

I had the same experience. Updated firmware and then I was told I needed to download and install Plex. Did that and things seem to work… kind of…

I am now having the problem of my folders and files being renamed. Not all of them but a hell of a lot of them. So a folder and associated files that used to be (Folder:) XYZ Show (Files:) XYZ Show - S01E01.mkv, XYZ Show - S01E02.mkv, etc is now (Folder:) 381CVV~K (Files:) 3VL634~H, 3VL634~I, 3VL634~J, etc (those are the literal file names that I copied). The strange thing is that in one of the folder/file combinations that that happened to, I can find them in the plex app. When I look at the path (using plex) I can see the normal path but when I open the finder and look in the drive itself, there is no folder/file path to be found.

Right now the drive is still indexing and so I hope that the folder/file names go back to normal. If they don’t I don’t know what to do…

My Plex is updated (today), but still I am gettging a trasconding error.
This error did not happen before.

This is on a remote connection, not on a local…
But i didn’t have this before.