Os corruption problem possibly

I have the dx 4000, that will not verify 100% before freezing up. All drive lights solid blue until the point that it freezes up 74%, last reboot. I have the iso on a flash drive and plugged in the usb port. Are there steps that can be used to force the system to recover without the launchpad?

I have a very short window in the remote web access to see the system’s dashboard before the system failure (freeze up). 

I think it freezes because when it stops verifying all the hard drive lights go out totally. Hence the above question. I also notice on the display screen (while verifying) that the system is only recognizing 5.10 TB of  total space, this system is equip with 4 - 2 TB hard drives.

This is why I have come to the conclusion that possibly the os maybe corrupted to the point that it fails before verifying 100%. When I have logged in, I see the desired backup files still in place and can open folders up until the system freezes.

I hope that this device isn’t a lost cause, we have only used it since March 2014. From what I have read these hard drives are suppose to last way more than a year. 

Fyi, the system also freeses up during initial start up sometimes. Display says start up initializing… Blue light flashing above power button, as if it is trying to load, but never does. I left it go for 10 hours then rebooted again then it loaded up to 74% as discribed above. This is where I stand once again blue light blinking, start up initializing… 

Any help would be appriciated, very expencive paper weight .

Not sure what to tell you. First off there is no recover option from the dashboard before it locks up.  I don’t think your OS is corrupt has you can get to it/use it before the drive system seems to quit.

As a rule initialing can take up to 5 days but the system is still normally useable, though slower.  You should never pull the power on the box, but sometimes there is no other choice.  The 5.10 does seem odd, it should be closer to 5.5.  You don’t remember per chance what it said before?

If it has data you need, my vote would be to let it sit for several days and see if drive activity picks up.  If not you could try a recovery.

Perhaps you should contact WD support and see if they have any better ideas.

1 Like

I asked my admin if he remembered the total space of the drive before it went into this state of no return. He couldn’t remember for sure.

I read quite a few forums about not resetting this product (pulling power), but it seems to be the only way to try to see any progress/ remedy for the unresponsive os/ launchpad. 

My admin has alot on his plate so I am trying to help resolve this backup problem for him. In the past we were using the wd Sharespace device, that did all of what our needs were at work (unfortunatly we made a choice to purchace this device that didn’t make it a year before we were without a backup). My boss aloud me to take it home, I figured out that one of the drives prevented the use of that device. He is now using it while I try to figure out the issue with this one. I used the sharespace the entire time for my personal back up Raid 10.

I didn’t read forums, prior to rebooting DX4000 lets say more than once :). I just find it odd that i get different result when rebooting the system by turning it off with power button or by pulling the plug. I know that isn’t ideal but really it shouldn’t take five days for a os to boot just from a power loss. Probably to prevent loss of data I understand. What do I know this is the first SERVER I have ever touched. I have worked on hundreds of pc though (cable/isp/phone provider tech).

I had the device on all last night and all day today trying to be patient, display still read start up initiating… all that time. In the past start up initializing then would say intialation ok… it was stuck there for hours and hours, so i pulled power again. Next time after a day of being on the same screen I  pulled power again, start ok, innitialize ok, os load ok, verify up to 97% all hdd lights on boom hhd lights out blue light above power not blinking. Manual says power light blue not blinking means system loaded i say froze up due to remote access broken at that very moment.

I will take your advice and leave the start intialization screen on (power light blinking blue) for days on end to see if it pulls out of this disrepair, before trying recovery. It’s not like I have much choice, other than rebooting the heck out of it hoping it gets to 100% verifing before crash (freeze up). I don’t need the files on the system I just want to have access for more than a few minutes before crash.

This might eventually be mine to sell for profit or to use for my personal use, if I can get it loaded. My boss really likes the WDsharespace better just for the simplisity of the firmware, he is thinking of buying the My cloud EX4. I think this is more to his liking cause how simple it is, vs. this “server”. 

Like I said, normally the machine is just slow for 5 days while it initializes.  I think you may have something “wrong” that is grinding it to a halt.

The DX4000 is a good box, it is just difficult because it does not have a video port.

Just depends on what your needs are.  WD has a lot of good options.

If you want to describe your needs we can try to help guide you on a solution. I gather you do not need the server t run a Line of Business application.

1 Like

Thanks, for your time. 

Time will tell, i will re-post if i have any other reports or results.

I kinda was wondering if there might be a power suppy issue, that might explain why it verifies to different persentages.

and why it responds in different ways while powering up.

thanks again,

Like a rock… 

As it turns out I was’t following the recovery procedure correctly. 

I contacted my son whom has a bachelor’s degree in networking, technically he just read the directions in the administrator user guide and told me dad you should have figured this out. lol. After actually following the direction I think the device might still be usable. 

It is “recovering initializing” currently, wait for it to say “recovery started” like the guide recommends. It’s been in this state for going on 3 hour or more. I guess I need to keep waiting  unless “recovering initializing”  is the same as “recovery started”. I plan on leaving it run until it shows “recovery started” , but I am just concerned that the device is waiting for me to hit next in the recovery application screen on my technical client pc. 

If anyone has had experience with recovering/ upgrade this DX4000 and know what the lcd says on the device or when the next button is suppose to be pressed It would be greatly appreciated.

If I don’t see a reply by tomorrow I guess I will hit next to see what happens. I have a little knowledge now that I have read the manual :slight_smile: to just go through the process again if I fail tomorrow.

Gramps, I would like to help you get keychains but am not sure what to do to give you kudos. :). 

My vote is to do what the PC screen says to do.  Once the lcd says recovery, I have never seen a 3 hour wait before time to press next.  If you hit next and get a msg it could not find the server, well that is bad, and start over and do it your way LOL

1 Like

I hit next couldn’t find server, dang it, so I am going to try what I noticed in another post. Download the upgrade/recovery iso on a different pc it worked for him so I will see. 

you do have a dhcp server on the network?  You have blinky lights on the server nic and you verified you have a good download with a md5 hash checker of some sort

Yes I have dhcp setup on my router, and I see the mac of the server for a brief time cause my router assigns it a ip. I am pretty sure I checked md5 on the first download and it checked out ok. Maybe I didn’t check it properly, I only used the md5 checker that one time cause of wd’s recommendation.

I plan to try the download when I get off work on my second pc and a different router. As you know I have been try to get the server up and running for almost a month now. I think I am getting close. I originally thought the system was corrupted, now I think there was just a problem with the files that were trying to restore. Last night I ran the application that restored the raid (wiped it) and now the device seems to respond constant. Where as before it would get to a certain point and freeze at different intervals. Luckily the data was not important to me.

I just hope that I get it upand running again so all this wasn’t for nothing, fingers crossed. 

Like a rock…

I was able to connect to the server after downloading the recovery files on my windows7 laptop. I guess there was something within my windows8 machine that was preventing me from accessing the server as the recovery app instructs.

I continue to have issue trying to complete the recovery, the system keeps freezing prior to a total re-formatting during the recovery. I don’t understand why the unlocking of the drives works fine, recreating the raid or storage works fine. But the factory default recovery freezes and will not complete the recovery. I got as far as formatting before reload then the client pc says cannot connect to the server to finish recovery. In the message it says restart the server and try the process again.

I notice the device hd light are blue when it appears to be formatting, then all of a sudden the all  lights go out. Then a few minutes later I get the message server is not connected (broke froze up).

I am wondering if the mother board or memory is what is making it not fully load properly. If so this might explain why the device stopped working from the get go.

I am going to check tomorrow where this device was purchased and if they still have the receipt to try and get a rma going.

I just notice there is one more thing to try before the rma, I wasn’t aware I could reformat the drives diskpart/clean then do the usb recovery. I think I will try that as long as it doesn’t void the warranty possibility. I noticed a recent post explaining a process I haven’t tried yet

Gramps can you think of a reason that I would have access to the server for part of the recovering process up till the formatting part. I noticed the application says formatting an has a view of a bar that looks like it should show the formatting process but the bar doesn’t ever fill up, then a couple minutes later I get the message stating cannot connect to the server.

I am going to leave the server keep running over night to see if there is any further progress beyond recovery started.

Like a rock…

I tend to agree with you that something is broke.  My only suggestion is to hook the recovery PC directly to the server no switch/hub etc.  You will need to set the recovery PC to DHCP if it is not already.  Both machines will get an auto imaginary IP and be able to talk to each other.  This will eliminate any network drops.

Then just let things run untill it works or gives an error

Cleaning the drives will not void your warranty


As it turns out the dx4000 is under warrany yet, I just emailed support for my RMA inquiry.

I wiill post any additional info I may have pertaining to my system once it returns form repair. I just hope to have a restored device as a end result. 

Thanks Gramps, you are a big help from all the post I have read with your advice and the advice you gave me here on the post I created.

Like a rock…

1 Like

I thought I would let everyone know that WD replaced the DX4000 that was under warranty. All I had to do was pay shipping and be patient, if I had to do this over again I would contact WD support first vs. trying to resolve a defective product through trial and error.

I guess I am just used to being able to fix things no matter what it is via the suggestions of others on the internet.

The new device has been running as it should, very nice having a server/storage device that I can rely on.

Thanks to all that helped me.

Like a rock…