Problem Starting

My DX4000 is stuck. It just says “Startup Initializing…” and the blue light just keeps blinking. I left it on for a couple days like this and it never changes.

I have tried to power on with the USB key and holding the reset button but the display never changes. I have verified the USB key was created successfully.

Not sure how you can verify the key was created succesfully.  If you hold the reset button for 30 seconds while powering on, I am not sure you have a good thumb drive.  Make sure your download is over 6gb.

Mine takes 5 days. It seems like forever but it does finish eventually. I have the 4X3T HDs. I freaked out too but these guys in the forum calmed me down. Kept cold starting and rebooting before that.

I just rebuilt my 2nd DX4000 with 4x 4TB drives. It only took half a day to build. Network performance may be a factor here, as I have wired gigabit ethernet.

It should only take about a minute from the time you turn on the DX4000 with the recovery button depressed until the screen changes to the “INITIALIZING OK. LOADING RECOVERY” message. It is usually best to clean the drives first.

I have 2 DX4000’s with 3tb drives.

One of them I can get into recovery the other the recovery button does nothing.

That is how I know the usb key is working. One of them will go into recovery mode the other one never changes the lcd.

Network perfomance has nothing to do with recovery as it is just the soft raid rebuilding (it the bluescreen that say its going to check your hard drives because it wasn’t shutdown right).

Does anyone know how to hook up vga to these things?

Here is a video of what is going on

No way for us to connect a monitor.  Does your other box say starting that quick?  Just curious.  I have one of the very first units and it takes a while before anything actually shows on my LCD whether it is normal or holding the button.

Even if it did boot after 5 days, I would not want it if the recovery button does not work.  Since you have 2, you can pretty well tell this one is broke.  Send it back :neutral_face:

I second the motion in the other post. If you have two DX4000’s and you have the liberty of attempting recovery, call WD and get a replacement unit.

You are correct about network performance; I was thinking about the recovery screen that shows the progress bar. I temporarily forgot that the image is on the USB thumbdrive.

Do the early units have 2GB of RAM?  I’ve upgraded both of mine to 4GB.

I know some very early units had 1TB drives, something that does not appear to be available any more (not that you’d really want them these days). I was wondering if they also increased the RAM.

Technically, the ARK chipset does include video, although I haven’t seen any interface for that as yet to be able to get to it. Theoretically it might be possible to tap into the PCIe buss, but that would DEFINITELY void the warranty :wink:

There are USB monitors available, as well as USB monitor adapters. These drivers would be relatvely easy to obtain and install, although we would still have the problem, as pointed out in another previous post, about the POST/BIOS phase not recognizing the devices without a BIOS mod.

Some enterprising software gurus out there might be able to code up a shim that would enable this feature. Something that is most likely far above my skill level.

I would rather not send it back if at all possible. The hassle is annoying and I don’t have the box since it worked for the first couple of weeks until I tried to update to the latest version.

It would be nice if there were better documentation as to the boot process. As in:what does holdig the recovery button actually do. Is there any other “hidden” features, such as the hard reboot by holding the power button. Is there a way to hold the up or down arrows and do anything. How about booting from cdrom? The system builder information would be helpful.

As far as I can tell these have an uefi bios and there are some uefi executables that change the diaplay and control the boot process. Some uefi bios have serial or network diagnostic modes. Does this board have a serial port that I can use or usb serial so I can see where it is getting stuck?

What about putting the drives in another machine? I have a dell 9010 that has onboard intel raid that has a uefi bios.

The other idea i have is to create a usb key with winpe and ms dart and trying to remote into that.

If it messed up doing a firmware update, I think you are truely toast.  If the firmware is not booting properly it really does not matter what is on the drives.  So putting the drives in another box I do not think will be any help.

If pressing the button to boot from usb does not work, I doubt it would boot from dart/pe

Yea, if we had any clue what the screens said at boot, you could try a usb keyboard and reset to defaults or select a boot menu.

If you have a Guardian Express plan or were really, really, nice to the WD support people, you could get an advance replacement.

I imagine holding down the recovery button initiates a built-in bootloader. It would be interesting to see if it would load ESXi or some other oS that way, if you had a pre-built answer file for unattended installation.

Putting the drives in another machine would probably be fruitless; you generally have to setup the RAID in the BIOS extension, and sometimes the drives order won’t be what you expect. I have a Gigabyte mainboard with it. You would be risking hosing your array.

There are other posts in the forum about installing other os’s but no detailed information. One would think there would be at least one person at wdc that was as energetic as the public about this device and put outsome useful info.

I undestand that wdc has to protect their ip and manage the scope of their support to the shipping configuration.

But it would be nice for those of us that have the technical ability to self support and customize to our needs if information was available. Its a value add option.

I am thinking tomorrow I will make a linux boot uefi usb key to see if that will work.