Ongoing problems with proper smb mounting in macOS

i’ve always had some issue with properly and consistently mounting a few shares from my my cloud on macOS (since before High Sierra up to High Sierra) …

what i have:

wd my cloud with the following shares:

Public
My_Book (connected via USB to the My Cloud, for safepoint backups)

i’ve tried AFP and SMB mounting methods, and adding those items to Login Items.
the My_Book always mounts at startup without an issue, but Public i would get an error message (cannot connect to server), or finder would show the contents of Public with red dashes on each folder (inaccessible).

in the past i’ve also used apps such as Drive Mounter to automate this, but i have an issue still with mounting both shares without problems during macOS startup. whether i use drive mounter for both shares, or not use drive mounter and instead go with adding them to login items, still get issues.

i’ve cleaned out the keychains as well. when asked to connect to the server i use:

smb//:wdmycloud/Public and smb//:wdmycloud/My_Book as registered user “admin” and the admin password.

is there any kind of deep cleaning i need to do in macOS, Finder, etc. to remove previous paths or mounts that might be causing this, or is this being caused by the my cloud where the drive is not ‘ready’ for some reason during mounting ?

right now, what works is the following:

use drive mounter and only mount the My_Book share.
use login items and only mount the Public share.

i never have a problem from windows 10 side, they are always accessible and mapped in File Explorer.

this is really nerve racking, and it’s random. sometimes it happens at login, sometimes it does not.

i assume that some experienced NAS users on this forum know exactly why this happens … perhaps someone is kind enough to share their knowledge please ?

i am at the moment running the latest firmware (04.05.00-320).
macos version 10.13.3.
smb://wdmycloud/Public is how i connect

i want to get to the root cause of this issue.

How is your Mac connected to your local network?

via wifi

Then I would investigate your WiFi connection for the Mac, since there seems to be nothing wrong with the MyCloud (working fine with the other accessing devices).

general research over the past couple of years with online searching suggests to me that mac os is weak and lacking when working with NAS drives or connect to server in general. i’ve not owned a time capsule before but i’d assume that apple’s product would connect without issues.

i suspect it has something to do with their neglect of perfecting the SMB or AFP connection to a server.

since i have a few years messing around with this, i could tell you that i’ve had better success working with 3rd party apps, such as ‘Drive Mounter’ (app store) and more recently ‘ConnectMeNow’ (https://www.tweaking4all.com/os-tips-and-tricks/macosx-tips-and-tricks/connect-network-shares-mac/). the faster of the 2 is ConnectMeNow.

so these programs i figure are doing something to permit successful share mounting each time.

i was under the general assumption for some time now that the mycloud NAS was working ok. but i did notice that other models that are based on different firmware (02.XX.XX…) have additional settings in the dashboard to allow things like NFS, AFP, etc. type of connections. whereas the model i have i think is by default setup for SMB.

wifi connection works good at each login, so i doubt that’s an issue.

i have dependencies living on the NAS that interact with software on my computer - such as Chronosync (it relies on the path to specific folders on the NAS) and itunes (i store my ‘itunes media’ folder on the NAS). when the NAS doesn’t mount automatically at startup - i have to manually mount it.

i have disabled thumbnail generation, media scanning, tweaked setting in the twonky settings page as well and deleted the thousdands of wdmc folders which were there.

that so far has improved how the my cloud works. i am once again getting emails for activity and the dashboard is responsive and the quick self test is working.

not satisfied that i had to go do all of this in order to get the nas to operate like it should. wd handicapped the device on their own, leaving end users with issues to deal with that they have to research to figure out.

i just discovered my previous post content was edited.
so consumers cannot really speak honestly on this forum, WD won’t allow it … !