Nothing happens when I plug in my new Passport for Mac

I had purchased a Passport for Mac some months ago, but I dropped it and it would never work again. Before that, it worked great: plug and play as advertised
I just purchased another, and when I plug it in, nothing happens. It is not backing up. I see the icon on my desktop and I can run the diagnostic, but nothing is happening. I tried undocking it according to instructions. I tried rebooting my computer. Still nothing. And no backup files appear in its folder

Which WD Passport is the one you purchased? Some units will need to be re-formatted before they can be used on Mac OS systems. Additionally, even if the unit is a Mac-ready hard drive, it runs an independent backup configuration from your previous unit and will not automatically start copying your files without an initial setup.

Thank you. I purchased the Mac version and already did the initial set up.

Which OS are you using?
Are you also using Time Machine along w/the Passport For Mac?

Uninstall the Passport’s utilities, repair permissions & restart your comp.

If no ones suggestions are working, you should CALL customer tech support. You are still under warranty. Take full advantage of it before it runs out.