Not seeing some network shares

Hi folks!

I recently added another HD to my system, moved some files over to it, and shared some folders on it.

Unfortunately my WD TV Live doesn’t see the new shares. Right now for testing I have everything wide open - no passwords needed, nada, and I can see all the shares from other devices in the house (even my locked down work laptop that isn’t on the same workgroup).

I’m running the latest firmware, have tried rebooting both the PC and the WD TV live device, reset the WD TV Live device multiple times, etc. It just won’t see any shares on the new drive (I’ve tried sharing the entire drive, sharing a few folders, etc).

Any suggestions on how to troubleshoot this? As I said, the shares work fine on other devices with no authentication required, but not for the WD TV Live :frowning:

See if this tutorial for troubleshooting helps:

Hi, thanks for the reply! I did try those and everything shows up correctly, even  another PC that is on tightly controlled domain  can see the shares and access everything when connected to my network.

Basically from my work laptop I see shares:







the WD TV Live shows me



All shares have the exact same permissions, which is full read/write for ‘Everybody’ and my networking is setup to allow access without user/password. Basically it is just wide open.

What are the names of the missing shres?

“Video” and “H” and “Flippyflop”. Yeah, I’ve tried creating random small new shares as well with a single video file in them and they never show up.

I thought this might be a master browser issue, as both my PC and the WDTV were showing as master browser with nbtstat, but even after fixing that issue I still can’t see all of my shares from the WDTV. 

OK, easy way to fix is you need to 

  1. Delete all your Network Shares

  2. Delete Media Library

  3. Reboot SMP

  4. Wait until “white” LED stops blinking after Reboot

  5. Remap your drives… then

6. Wait until “white” LED stops blinking

All should be good.

Cometimes the Media Lirary or the Network Shares get corrupted. I find this is the best way to fix (even though its painful to do).

Additionally, you are limited to 10 Primary Network Shares in FIRMWARE above 1.10.XX (before that it was 20 shares).

Cheers LB

HonoraryOrange wrote:

I thought this might be a master browser issue, as both my PC and the WDTV were showing as master browser with nbtstat, but even after fixing that issue I still can’t see all of my shares from the WDTV. 

So I understand where the issue is, when you say it’s not seeing the shares, I just want to clarify:

Is it not seeing the SHARES themselves (Such as when you go to Select Content Source (red button) - Network Shares - Windows Shares - Select the server - Shares are listed…)

Or is not seeing the CONTENT of the shares?

Sorry for disappearing on this one for a while, things have been busy.

Anyways, I’ve determined what the problem (oddly) seems to be.

First, to clarify your question: I need the right Computer listed, and after I select it and log in, I do not see all of the network shares.

The ones missing? They’re the ones being shared from USB hard hard drives that are attached to a USB Hub. These drives are 100% functional and work for everything else, and show up properly on every other device except the WD TV Live. Also if I move them out from behind the USB Hub they will show up fine.

(To be clear: Computer has multiple shares, some from the regular hard drive, some from USB devices attached to the computer. When viewing the list of available shares on this computer, the WDTV Live does NOT show the shares that come from the USB devices behind the hub. If I take the devices off the hub then they do show up. Unfortunately I don’t have enough USB 3.0 ports to do that.)

Any ideas?

And just to add to the crazy, I’ve 2 more things to add:

  1. This reproduces with any USB hub

  2. It reproduces when the devices attached to the USB hub are part of a Storage Space in Win8. Which is kind of bizarre because the WDTV shouldn’t even be able to tell it is a USB drive or anything of the sort. I mean this is seriously just a network share. Everything else can see it. What gives?!?!

Anyone got any ideas?