Network Shares No Longer Working

I’ve read everything I could find on this forum and elsewhere on the internet.  I’ve been unable to solve my problem with any suggestions so far.  I’ve tried calling support as well, but didn’t have any luck there.  I’m supposed to call back tomorrow to speak to a level 2 support agent.  Below is a description of my problem.

This past weekend, I decided to move all of my shared files to a new hard drive becasue the old one was filling up.  I recreated the shares for each folder giving Read/Write permissions to “EVERYONE.”  Now, when I log in to try to view the files on the WDTV, I only see the “Users” folder.  The network shares worked perfectly before I moved them all to a new hard drive.

Also, I’ve tested and I can acess the files/folder from any other device on my network.  I’ve used the “net view” command to verify that the folders are visible on the network as well.  Support had me try factory resetting the WDTV Live, but this did not help.

Anyone have any other suggestions?

Thanks in advance.

I don’t know if support already helped you, but how are you setting up the network shares?  Is it another network drive?  Is it through another computer? What OS is on that computer if you’re using one to set up shares?

I’m on the phone with them now and I’m not too optimistic.

I setup the network shares on my Windows 8.1 machine by sharing the folders (Right-click Folder->Properties->Share) and giving Read/Write permissions to the EVERYONE group.  It is not a network drive.  It is connected directly to the Windows 8.1 machine via USB (like the previous drive).  It is really weird.  Every other device I’ve tested has no problem seeing the shared folders/files.

Can you check this KB article and see if it gives you any help.

I would also make sure that you’ve enabled File Sharing on the Network Share (Samba Server) on the WD TV (page 30).