WDTV not seeing shares

Hi Guys,

I’m having an issues with my WDTV Streaming Media Player.

The WDTV can see shares on my PC, but not on a 4 drive USB3 drive bay I have attached to the PC. I have been tinkering for days but cannot work out the issue. Tried rolling back fw but didn’t fix the issue.

TIA for any help :smiley:

make sure the drive is shared. You can see some people icons on the drive (heads and shoulders) if it is. The WD TV Live will not see the drive if share is not enabled.

Also right click on the drive icon, go to properties , and the shariing tab.

Click on advanced sharing and then check the box which says share this folder. Go out and press the share button. Sometime you will have to share the folders in your HDD too.

A good way to check if your drive is shared is to go to computer then click on Network then cick in computer. .  All folders that are shared will be displayed.

regards

Hi,

The drive is properly shared, but still not showing up. I’ve noticed shares on my pc work, while shares on the attached drive bay do not. I’m sharing both the same way. Can anyone help? Cheers

ForgeNZ wrote:

 

A good way to check if your drive is shared is to go to computer then click on Network then cick in computer. .  All folders that are shared will be displayed.

 

regards

 

The drives on the external bay show up there, yet the wdtv cannot see it.

On the PC, open a CMD window and execute the command 

net share

Post the results.

TonyPh12345 wrote:

On the PC, open a CMD window and execute the command 

 

net share

 

Post the results.

 

 

Microsoft Windows [Version 6.2.9200]

© 2012 Microsoft Corporation. All rights reserved.

C:\Users\brett>net share
Share name Resource Remark

ADMIN$ C:\Windows Remote Admin
V$      V:\     Default share
U$     U:\     Default share
T$      T:\     Default share
IPC$          Remote IPC
C$     C:\    Default share
D$     D:\    Default share
E$     E:\     Default share
F$      F:\     Default share
G$     G:\     Default share
W$     W:\   Default share
Backup Media - 1     T:\Backup Media - 1
Backup Media - 2      U:\Backup Media - 2
Backup Media - 3      V:\Backup Media - 3
Backup Media - 4      W:\Backup Media - 4
New Movies     F:\New Movies
The command completed successfully.

C:\Users\brett>


The “New Movies” share is the only one that shows up on the wdtv.

Thanks!

Hi Guys,

I followed the advice at http://www.mede8erforum.com/index.php?topic=64.msg217.

I can now see the the default user shares on my wdtv, along with the the local shared folder i was already seeing in the wdtv.

When it comes to shares on my external drive bay however, no luck :( This is becoming a major PITA! Can anyone offer any help. It would be most appreciated.

Cheers

Just for giggles, try changing the share name of one of disks.

From Backup Media- 1 

to “TestShare”

or something like that – then reboot your PC and the WDTV and see if it picks it up then.

I seem to recall seeing previous issues that appeared related to share names containing spaces and non-alphanumeric chars.  I would definitely try as TonyPh12345 suggests, but I would say to rename your shares to Backup1, Backup2, etc.  Spaces and special characters should generally be avoided for highest interoperability.  I tried to find some documentation on what “standard CIFS” allows for share names, but was not successful.

I agree with the special characters train of thought

in theory here’s how this would work

linux mount cmds might looks something like

mount -t cifs -o /blah blah

the character - indicates that an specific mount option is selected

in my example -t

or -o

so in theory the system sends the cmd and interprets -1 or - and errors out on those shares

You might be onto something here. According to a short article in German magazine c’t, Micros~1 has changed the name resolution order in Windows 8. Instead of Netbios first this is done via DNS which allows only a–z, 0-9 and - (and apparently then also applies to Netbios).

gthjh wrote:

Hi Guys,

 

I followed the advice at http://www.mede8erforum.com/index.php?topic=64.msg217.

 

I can now see the the default user shares on my wdtv, along with the the local shared folder i was already seeing in the wdtv.

 

When it comes to shares on my external drive bay however, no luck :( This is becoming a major PITA! Can anyone offer any help. It would be most appreciated.

 

Cheers

Have you tried the new firmware that was just released?  It would be good to know if there is any change.

I did not see any networking fixes in the release notes, were there some?

Thanks for your help guys

I renamed my shared folders (getting rid of the special character and space) and now it works beautifully. 

eg

Instead of

Backup - Share 1

I’m now using

BackupShare1

Thanks again, this was driving me nuts!

Hmm.  Well, I’d count that as a bug, But glad there’s a workaround…