No sound with DTS and pass-through

I recently bought a WD TV Live to replace my first gen WD TV, but after updating the firmware to 1.05.04 i’ve not been able to get sound from mkv files with a DTS stream to my receiver (connected with HDMI only) with sound output set on digital pass-through. The media files are stored on a 500GB Lacie 2,5" portable disk, which is connected to the USB port of the WD TV Live. When i change sound output to stereo i get sound, but of course that’s no solution.

I’ve tried everything i could think of:

  • rollback to different firmware versions namely: 1.03.49, 1.04.22 and 1.04.31

  • loading default factory settings

  • reset button on the side

  • disconnecting the power for some minutes

Nothing helped though and eventually i gave up and hooked up my old WD TV which plays all mkv movies with DTS stream just fine.

What else can i try? Because i’m now thinking of just returning the WD TV Live and revert to my old WD TV.

After you did the FACTORY DEFAULT, did you remember to go change your AUDIO settings back to DIGITAL?

Yes i did. If i wouldn’t had remembered that, i would have had sound. Since stereo is the default setting and with that setting the sound works as described in my original post.

Can you try going back to the settings and choosing “Stereo”, and then choosing “Digital” again and then playing a DTS files and see if that changes anything?

Tried that to no avail…

Was worth a shot, based on the other “forgotten” settings… feared it wouldn’t make a difference, tho. :cry:

So nobody knows what’s wrong? I even called WD and wrote them an e-mail, but they weren’t much help.

Also no sound with trailers from Apple in .mov format. Yesterday no sound with MKV and AC-3 sound too, but after resetting to factory defaults and changing sound output to digital pass-through again, it was fixed. Still no sound with the .mov trailer though and of course every MKV with a DTS stream is still silent.

I also experienced lipsync issues with AC-3 and digital pass-through and HDMI handshake issues (WD TV Live losing signal) shortly after playing a random video file, pressing the back button would bring the signal back.

How can there be so many problems with the WD TV Live? My old WD TV works much better (besides it’s limitations) and is way more reliable.

Sinergie wrote:

 

How can there be so many problems with the WD TV Live? My old WD TV works much better (besides it’s limitations) and is way more reliable.

There’s not.   Nobody else is reporting this problem.

I would suggest you go try a high-quality HDMI cable.   Go buy a really good one at a shop with a good return policy.   If it fixes the problem, you know what the issue was.  If it doesn’t, return it.

Also, exactly what make & model is your downstream HDMI device?

@TonyPh12345

I mentioned other problems as well not just this problem. I think my device is just faulty, but then again even if i exchange it for another one DTS might be fixed, but the other problems remain. Till WD fixes them “maybe” somewhere in the near future.

Hello everyone,

I’ve experienced exacly the same problem since I upgraded my live to the latest firmware, (there is no problem before that)

when I watched DTS movies there is no sound via hmdi or optic cable, onlye stereo works with DTS

I tried to rollback all old version one by one (include 1.02.21), I tried 3 hdmi cable (sony, belkin, hama) and 1 optic cable, I also tried these with my lcd tv and my brand new avr. but it still doesnt work with all combination.

I took my live to local service 2 times (in Turkey -> Logosoft), they did just update my device and sent it back to me and I don’t know what can I do now, I couldn’t find any solution,

pleaseeee helpppppp!!!

thank you…

Murat

any help???

MrtDzyl wrote:

any help???

Roll back to the version that DOES work for you.

If a Rollback does NOT fix this issue, then it is NOT firmware related.

TonyPh12345 wrote:


MrtDzyl wrote:

any help???


Roll back to the version that DOES work for you.

 

If a Rollback does NOT fix this issue, then it is NOT firmware related.

It could be firmware related as then the latest firmware breaks DTS pass-through somehow, since the same happened to my unit.

Can you tell me what model receivers this issue is happening with?

I’ve also had this problem - it’s not clear cut though.

A couple of weeks ago I tried to play an MKV file that only had DTS sound via my WD TV and my Yamaha RX-V667 receiver via HDMI and there was no sound at all (it worked if I changed the WDTV Live to Stereo), it also worked Ok if I connected via optical out direct to the receiver.

However - 

My TV is a UK Sony KDL40EX503 and the WDTV is connected direct to it via HDMI, I then connect via optical to the receiver (this is because the Sony will not pass AC3 via the HDMI audio return channel to the receiver - for whatever resaon - but the optical will). I suspect it’s the TV that won’t pass the DTS to the receiver.

To be honest I gave up and converted theaudio in the file from DTS to AC3, I can’t be doing with changing modes everytime I change file type.

So we’re no clearer I have never connected the WDTV direct to the receiver via HDMI so don’t know whether it passes DTS or not.

Patrick

UK

pgnlstuff wrote:

I’ve also had this problem

No, you don’t.   The problem being discussed here is people who have their WD’s directly attached to their AVR via HDMI.  You indicated the source of your problem:   Your TV doesn’t passthrough DTS audio to the AVR via optical.   VERY FEW TVs do that.

TonyPh12345 - You might be an ‘honored contributor’ - whatever that is - but there is no need to be so curt. My post is relevant to the issue albeit indirectly, believe it or not there maybe people out there that don’t know as much as you do.

Such an arrogant response - is totally unecessary…

Hello again,

in my case, My Live connected to my panasonic plasma tv (42G15E) via HDMI and connected to my panasonic avr (SC-PT580EG-K ) via optic. When I choose digital passthrough, no sound from TV or when I choose digital pt via optic, no sound from avr for all my DTS movies. All other format works via hdmi or optic and DTS also works when I choose “Stereo” option. And I was watching all my dts movies via hdmi on my TV before I updated my live to latest firmware.

As I said before, I tried to roll back to all old firmware but It’s same. I’ll take my Live to local service tomorrow and I hope to find a solution, I’ll write down here what we’ll find.

see you,

have a nice day,

Hello,

I went to local service and We tried my Live with Logitech Z-5500 via optic and It’s worked with my DTS movie. It still doesn’t work via HDMI but It’s not important for me, because I want to use my live with my avr via optic.

So, Altough My avr says it’s support to DTS, It doesnt work with DTS.

in my case, WD Live works with DTSs, I try to find a solution with panasonic.

Thank you,

Have a nice day…

Guy_K wrote:

Can you tell me what model receivers this issue is happening with?

I had this problem with my Sony STR-DA2400ES receiver.

@MrtDzyl

Just like pgnlstuff you don’t have the same problem as me. When you would connect your Live with HDMI directly to your Panasonic receiver and if you then don’t get sound with DTS streams then you would have the same problem as me. Like TonyPh12345 pointed out very few TV’s are able to pass-through DTS. So that isn’t a problem with the Live, but just a limitation of your setup and if it worked before maybe you had the sound output setting set on stereo without being aware of it.