1080p MKV file with DTS - no sound

I’ve been trying to play a 1080p MKV file with 6ch DTS audio on my WDTV Live player, and there’s no sound, only picture. I’m using an HDMI connection to a Sony STRDN1000 AVR and then onward to an Hitachi 42PD7000MA plasma (it can only do up to 1080i res, not 1080p ) , and I’ve tried using all three WD audio settings , stereo, pass-thru via optical & pass-thru via HDMI, all with the same result. I have successfully played some 720p MKV files with 6ch DTS without any problems. I’ve also tried using different firmware versions 1.04.17 , 1.04.22 and 1.06.15, but the 1080p MKV file won’t give me sound. Could this be caused by Cinavia (not sure if the file has it, or not) ? Is there any more firmware available after 1.06.15 to fix the bug?? All other ideas welcome.

1 Like

No, there’s no Cinavia.

Please post the FULL TEXT output of MEDIAINFO for a file that does NOT work.


I found this in one of the .mkv file’s txt attachments, hope it helps…


Format: Matroska

Format version: Version 2

File Size: 5.35GB

Duration; 1h 28m

Overall bitrate: 8652kbps

Writing application: Lavf51.12.1

Writing library: Lavf51.12.1


ID: 1

Format: AVC

Format/info: Advanced Video codec

Format profile: Baseline@L4.0

Format settings, CABAC : No

Format settings,  Reframes : 5 frames

Format settings,  GOP : M=1, N=12


Duration: 1h 28m

Bitrate: 7069kbps

Width: 1920 pixels

Height: 800 pixels

Display aspect ratio: 2.40:1

Frame Rate Mode: Variable

Frame Rate: 23.976fps

Color Space: YUV

Chroma sampling: 4:2:0

Bit Depth: 8 bits

Scan type: Progressive

Bits/(Pixel*Frame): 0.192

Stream size: 4.37 GB (82%)

Language: English/English


ID: 2

Format: DTS

Format/Info: digital Theater Systems

Codec ID: A_DTS

Duration: 1h 28m

Bitrate mode: Constant

Bitrate: 1411.2 kbps

Channel(s): 6 channels

Channel positions: Front: L C R, Side: L R LFE

Compression mode: Lossy

Stream size: 894MB (16%)

Language: English/English

I’m having similar problems… But my files won’t play at all. 

I hooked both of my media players (1 TV Live and 1 TV Live Plus) to the internet and it said they had software updates so I ran them on both players (in different parts of the house) and now when I go to watch .mkv video files, it says that the file format is not supported. These are video files I’ve played in the past on BOTH media players AND my computer without a problem, so it isn’t that the files themselves are corrupted. Is there any way to add MKV codec to the players and if not, how do I roll back the updates to the versions that worked? Thanks in advance for any help you can provide.

°º¤ø,¸¸,ø¤º° ø¤º°`°º¤ø °º¤ø,¸¸,ø¤º°

What I Have:

:heart: WD TV Live Plus

http://wdc.com/en/products/products.aspx?id=320 (Hardwired through Ethernet Cord)

:heart: WD TV Live

http://wdc.com/en/products/products.aspx?id=330 (Connected through Wireless Adaptor)

ø¤º°°º¤ø °º¤ø,¸¸,ø¤º° ø¤º°°º¤ø

ShojoBakunyu, Since you are asking a completely different question, you should start a different thread. You will get better answers that way.

Before rolling back, try pressing the reset button on the WD box. Hold the reset button for 1 or 2 seconds. Resetting sometimes fixes the type of problem that you are seeing.

I have a WD TV LIve Streaming Media Player with firmware 1.10.13.  I’m having a similar problem with a matroska file, below is the MediaInfo for the file:

Format : Matroska
Format version : Version 2
File size : 6.13 GiB
Duration : 2h 22mn
Overall bit rate : 6 152 Kbps
Writing application : Lavf51.12.1
Writing library : Lavf51.12.1

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : Baseline@L4.0
Format settings, CABAC : No
Format settings, ReFrames : 1 frame
Format settings, GOP : M=1, N=12
Duration : 2h 22mn
Bit rate : 2 958 Kbps
Width : 1 920 pixels
Height : 800 pixels
Display aspect ratio : 2.40:1
Frame rate mode : Variable
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.080
Stream size : 2.95 GiB (48%)
Language : English
Default : Yes
Forced : No

ID : 2
Format : DTS
Format/Info : Digital Theater Systems
Codec ID : A_DTS
Duration : 2h 22mn
Bit rate mode : Constant
Bit rate : 3 072 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 44.1 KHz
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 3.06 GiB (50%)
Default : Yes
Forced : No

 The WD TV Live is connected directly to my TV via HDMI.  The Audio output is set to Stereo.  I also tried Digital Pass-Through via HDMI only but still no sound either.  Is there a problem playing back the A_DTS codec?

EDIT: Updated product description.