No audio on MKV


#1

Hi:

I have just bought the WD TV HD media player. I have update it to the lastest firmware 1.03.01. But almost all the mkv above 2GB do not have sound. I tried on options to switch the audio but there is only one channe. I have connect the WD with HDMI to the tv (also I put on settings audio digital). Can you help me or should I go to the store and reclaim the money?

Thanks


#2

What is the audio codec on those mkv files?  (You can use Mediainfo for this, or any one of a number of freeware tools).


#3

Try using stereo in the audio settings, instead of digital.


#4

I tried but it happened the same. When I played this mkv it shows on the screen undetermined 1 (digital( or english1 (digital)


#5

I have installed the media converter of ARC that comes on the cd but it does not work with mkv, only avi. How can I find the audio codec?


#6

As mkelley suggest above, you can use a tool called MediaInfo to find the audio and video codec used in the file (along with a bunch of other useful info).  Download it here.

Also, if you have an older model WD TV HD (and not a WD TV Live), you’ve posted in the wrong forum.  The Live runs a completely different firmware and issues on the older HD model don’t affect us, making it hard to help you.

The correct forum for WD TV HD help is located here: http://community.wdc.com/t5/WD-TV-HD/bd-p/tv_hd 

If that’s the case, you can report your post to a Mod and they’ll move the thread for you (click Options and select Report Inappropriate Content).  :)


#7

OK I found which is the code, right now what I have to do???

Audio DTS

Video AVC


#8

I too have the same problem, and this seems to be the right forum as well… so why isn’t anyone replying…??

Is WD doing anything to play DTS audio in MKV files???


#9

If  you go to http://www.networkedmediatank.com/showthread.php?tid=20887  you will find a converter to convert DTS to Dolby or even Stereo. Follow the instructions and the converted .mkv file will give sound with your WD player.

Good luck!


#10

Thanks I have done it, and it works !!!. Althought I do not want to be every time that I am watching a movie, wasting 15 min in converting the sound. Probably I will go to  the shop to return the gadget


#11

I change the Audio option from digital to Stereo and that fixed the issue for me.