No photos found Android 3.2.1

I’m having trouble getting the Photos app to work on my tablet. I have a Asus Eee Transformer with Android 3.2.1. My photos are on a WD TV Live Hub with the latest firmware (3.01.19).

After installing the Photos app on my Transformer I get the activation code from my Live Hub. After entering this code the app lets me connect to my Live Hub. Then it runs a First Time Setup and opens a blue screen. On this screen there is the text: “No photos found”.

How do I get my photos from the Live Hub in this photos app? I tried clearing the cache, but this did not work. Do I need to change a setting on my Live Hub? Does anyone has a idea?

Where are the photos located inside the Hub and how long has it been since you activated the service and only? And what extension? Only JPEG and JPG are allowed if I remember correctly, and It can take days to populate the pictures.

I am having the the same exact problem. I have installed WD Photos on my Samsung Galaxy Tab 10.1 running 3.1 and my Galaxy Nexus running 4.0.2. I set in the activation code into both, but it says that there are no photos to view, from my hard drive (the ones avaiable synced from my mobile device gallery). I have not been having any issues with WD 2Go, my files appear on that, but I am getting nothing from WD Photos. 

My files are jpegs, but are still not showing up. 

Any advice?

All my photos are jpg. I dont have a lot to choose where to put my files. There is one folder: WDTVLiveHub, inside this folder i made several different folders, one of them is the photos` folder.

I activated the app a week ago.

Should I enable the MediaLibrary? Because this option is turned off.



Anyone found a fix for this problem? I have a Samsung Galaxy S2 and a WD MybookLive. All connects fine but says I have no pictures??? WD 2 GO works fine but doesnt show thumbnails so takes ages to find the picture you want to download.

Hopefully its a case that the drive is “processing” the pictures, I can hear it doing something over there…

Thanks in advance for any help!


If it has been over a week and you have fewer than 10,000 .jpg/jpeg files on the WD TV Live Hub, there may be something else going on. Please contact support regarding this issue and have them escalate you to the WD2go support team directly.

Mine has been missing since dec 25 . I did see a couple of pictures then i did firmware update and nothing since

Due to a known bug we are working on resolving in a future firmware update, you must toggle Mobile Access “Off” and then “On” from the WD TV Live Hub’s interface.

This will force the drive to rebuild the cache, thus re-transcoding your files again.

After a couple months of doing nothing I gave it an other try. The toggle Mobile Access to “Off” and “On” worked fine for me! It started rebuilding the cache and after a couple of days I could see over 10.000 photo’s!

I also completely wiped my Asus and installed new software, so I can’t point out exactly what the fault was.

Now it works fine, thanks for al the help.