WD Photos: "no photos found" message on folder view

When I first loaded the app and connected it to my WD TV Live Hub, it found my photos and arranged them correctly. After a few uses, it lost all folders in the Folder View. I can still see some photos in Album and Thumbnail view, but not all of them. The only way I have found to get Folder View back is to delete the app, re-install, and let it rebuild. But then after a while it loses them again.

I have the latest version of the app and firmware on the WD TV Live Hub. I did just update firmware again today and have not tried to reload the app, but firmware docs make no mention of a fix for this issue.

Any ideas?

have you tried resetting the HUB?

New firmware became available recently so I upgraded but it didn’t help. The only reset options I see on the hub are to reset to factory settings, which I don’t think I want to do since it is not clear what will be lost. I have tried disabling mobile access and then re-enabling but that did not help either.

I mean a hard reset… using the paper clip on the botton part of the device.

Will that erase the contents of the hub?


No, it shouldn’t delete the info.