No More Files Being Played On Gen 1 WD TV

Hi all. I’m very new to this forum, but not new to forums in general. I did a quick search but did not find anything that matched what is going on with my WD TV (Gen 1). If anyone can help, I’d sure appreciate it!

About a week ago, after loading some new movies onto my WD external HD, I connected to my WD TV (Gen 1) as I have done countless times before.
       The power light illuminates and the player starts to “scan the drive for media files”. I figure that it is reading the new movie files that I loaded onto the HD.
       The player seems to be stuck in the “scanning” stage. I’ve let it sit there for up to 12-15 minutes and it will just “scan” with the progress wheel spinning. Also, the Power light will be illuminated steadily, but the USB indication light will blink - that is new.

I’ve gone into the HD and removed the “New files” that I mentioned earlier. I thought that one of them might be corrupt. That didn’t help.

I have tried downloading the newest firmware, which I think is V1.03.01 (for the Gen 1 WD TV).

I got impatient with the Scan and decided to look in my files on my player. I can access all my files (movies, music, pics) but I CANNOT PLAY any of them. I just get a black screen. I have all sorts of file types on the HD: mostly MP3s, AVIs, MKVs.

I’m getting very frustrated and worried that something is wrong with my player.

Can anyone offer any advice or guidance on this issue? I’d sure appreciate it!

It’s almost guaranteed that you tried to play a .mkv file that has compression in the headers.

Unplug the WDTV for a while… the longer, the better.  Once, I got fed up and left mine unplugged for 24 hours, but 10 minutes should be more than sufficient.

After you plug it back in, press the paperclip reset button on the side (next to USB1) for a few seconds.

When it reboots, you should be back in business, until you play another .mkv that uses compression.


Your best bet would be to download

and then run MKVFix to automatically scan your media and have it re-mux any files that have compression.

I know MKVfix works with v4.3.0 – it requires it… but I believe there are issues if you try to use v4.5 and v4.6, so stick with v4.3.0 to be safe.

FWIW, my first post in here… way back when:

RoofingGuy wrote:

y3ell wrote:

I fixed the problem… If you reset or unplug your device it will work.



I’m finding that to not be the case.  At first I didn’t know what was going on.  All of the sudden, it “stopped working”.  Wouldn’t play any audio files; wouldn’t play any video files.


I eventually noticed that when browsing, there’s the box at the top, like if you’re browsing with an audio file playing, with the name of one of the compressed-header .mkv files in it.


So the player is too busy not playing the compressed-header file, to play anything else, audio or video.


I’ve done numerous "reset to default"s… I’ve done numerous paper-clip resets… I’ve deleted the .db and other files in the .wd_tv folder… I’ve left the WDTV unplugged for over 24 hours… and yet, when I turn it on, once it has scanned whatever drive is attached, there’s STILL that “audio playing” box at the top, with the name of the compressed-header file that “broke” it.


I don’t know what else to do to not have it re-try playing the file when the box is turned back on.  And that’s VERY odd, since it doesn’t resume other movies or audio files when turned on (or at least it never did in the past).


Sure, I can re-mux any file that happens to have compression, so that this doesn’t happen again, but right now, I’ve spent over a week trying, and I’d just like it to be able to play the files that it used to play.

In my case, it took deleting the .wd_tv folder AND leaving it unplugged for an extended time AND the paperclip reset AND “Reset To Factory Defaults” when it was done resetting.

I’d thought mine was dead too and was in full panic mode, because all the “just do this…” posts weren’t working for me.

Mine’s still working fine almost a year after that scare.

I’m still not clear why the Gen1’s seem to “remember” what file they were stuck on and resume trying to play it when you turn the box back on, when the other WDTV’s didn’t seem to exhibit this behaviour, but that’s rather secondary to getting it working again.

i have a similar problem, and nothing seems to help?

Thanks for any advice.

i`ve deleted files in .wd_tv on HD

left up plugged for 24 hrs and done reset on re-power up

.Played .avi file until it froze, chose another, went back to files in wrong format.


ok thanks for all the feedback…

took the WD my book essential and backed up the films on it, formatted it, wrote zero`s with WD software, reformatted and added the firmware to it, popped on a couple of movies to try it out.


so going to buy one of these instead;