No ip address


#1

Hello all,

I just updated my WD live to the .21 firmware and also experiencing the my laptop trying to get software drivers for it …not sure what the fix is for that but tried the post for resetting ,restore default and power cycle and nothing worked.

The networking issue I have is my laptop is connected to my wireless network and the live is lan hard wired to my laptop.

I have my lan to auto settings and the live to also auto detect and it shows me a ip but when I try to connect it does not work.

File sharing is enabled

Media sharing is enabled

I can access the live from my laptop and brows my flash drive connected to it but cannot connect the live to my laptop shared folders.

I however do see my laptop showing up under shared network in the live menu but it fails the connection process.

Not sure what to do next and would really like to have my live as auto.

Any assistance you all can provide is greatly appreciated.

Thanks again

nbrebel


#2

What you’re describing (Laptop is Wireless, LIVE is Wired to the Laptop?) doesn’t make sense.

What is the IP it is showing you?   If it starts with 169, then that’s not a “real” IP address;  that’s the “I can’t get a DHCP Address” address.


#3

Y does it make no sense?

I have no usb wireless device to connect the live to

My television is out of lan and AV cable range from my router

No portable harddrives

So the only option I have till I resolve this is to get the laptop connected wireless closer to the live and use my lan cable on it to get the stuff from my laptop to it instead of transferring it to my 32G flash drive and using that.

Yes I get the 169 ip and dont have a clue what to do from there. So if you can assist please do

Thanks again for you prompt assistance


#4

You’re getting 169 because your laptop is NOT a DHCP Server. 

You’ll need to set a IP address manually.

Example:  If your WIRELESS is 192.168.0.x (on the PC) with a mask of 255.255.255.0 then set the WIRED adapter to 192.168.1.1 (mask of 255.255.255.0) and set the WDTV to 192.168.1.2 with the same mask.

What you’re doing is very unorthodox.   It’s bound to have problems one way or another unless you’re very familiar with networking.   I build datacenter networks for a living, so this makes sense to me.   Your mileage may vary.


#5

Hey Tony,

Thanks for you response,

My wireless ip is actually 10.0.0.1 because of the router DHCP

So if I catch what you are saying correctly

I can set an alternate ip and mask on the lan

say  ip 10.0.0.30  mask 255.255.255.0

and on the Live

ip 10.0.0.21  mask 255.255.255.0

When I  check connection on the live it does detect  ip but fails the DNS test

Was wondering what I should set for the gateway and the DNS

I have tried

10.0.0.1 for the gatewa and the DNS on both the lan and the live but he live still fails DNS

Was wondering who can i get it to get past that? Was looking at BRIDGING the LAN and the wireless connection but do not know what settings to use on the gateway and the DNS so looking forward to you response.

I am looking for a wireless USB and saw the list of devices and was wondering if people had good results with the buffalo mini and the dlink140.

 But those are not available here so I will have to get this to work on wires first and wait till the devices get here.

Thanks again for you assistance.


#6

Hmmm.  I’m surprised your Laptop doesn’t get confused by having both the wireless and wired in the same subnet, but oh well.

I don’t know how you’ll get beyond the DNS test.   As far as I’m concerned, the WDTV should NOT abort due to a failed DNS.

Anyway, if you set your laptop to bridge the Wired and Wireless, then you’ll set the GATEWAY and DNS addresses to your router.    Also, if you bridge them, then DHCP should work on the WDTV.


#7

Tony,

Well if not those subnet then what do you suggest?..dont want to have a confused puter.

I have bridged both the wired and wireless and the live is has passed all the tests. I am able to connect to the live365,flickr

but no you tube …how is that done?

also for others

windows firewall is ON

auto login to network is OFF in networking on live(you will be prompted to enter user and password if password for Windows networking sharing is enabled)

share wdtv live is ON on live

I did have to make an entry for ip ranges in my MacAfee 10.0.0.1 (because that is the gateway address being used when bridged) as trusted

under network and sharing EVERYTHING ie enabled except printer sharing

looking forward to you response tony


#8

If Bridging is working now, then I’d leave it as-is.   Besides, you want to get your WDTV hooked up by itself (without the need of the laptop.)

I can’t imagine why YouTube wouldn’t work for the WD if it IS working for the laptop at the same time.

You might try turning off your MacAfee entirely to see if it helps…


#9

Tony,

Thanks again,

I have started searching for a usb wireless and well saw the bufallo but think that mini may be a bit to small for good range through walls …so want one that can at least pass the signal through 3 walls at the same level…any suggestions or without breaking the bank.

I would like to use a separate subnet mask just to make sure I dont confuse my laptop …wireless and the router. so will try and change it with something else and see how it peforms …I can always go back to what works.

well that seems the only option left to try with youtube…

thanks again man.


#10

just got my dlink usb 1.25 Ver A1 Firmware 1.0 wireless adapter and it works great.

For anyone following this thread I also was able to get this working with my lan cable directly connected and wireless and lan on a bridge network.

Just need to follow the settings that you give the unit so it will be manually configured properly and suppose the same may apply for hard wired cable systems that are not dhcp enabled.

Good luck to all with this unit