No DVD menu in new beta firmware release


#1

Hi,

I am using the WD TV Live with the new beta firmware .38 connected through analog video and audio to a normal tube television. I try to play back various DVDs (press  “play”-button on the  video_ts directories created with cloneDVD, located on a network drive). The playback starts with the main movie but the “menu” icon in the options menu is still deactivated. The files are ok. Other software (e.g. Nero Showtime) finds the menus and allows the menu navigation. When I copy the files on a DVD any of my DVD player will play them back with full Menu support.

Any Idea what I am doing wrong?

thanks

Sguidati


#2

Hi Sguidati,

can confirm the behaviour at my site as well with 1.03.38_V.

Used dvdshrink and dvdfab to create 1:1 ISO and hard disk folder copies for my tests.

DVDshrink, ISO file + “enter” and “play” show the right behaviour and menu is displayed and functioning (“option” shows the menu icon available)

DVDFAB/DVDshrink,  VIDEO_TS folder + “play” — directly starts the main movie, neither the menu is displayed nor is it available using the “option” key !!!

DVDFAB/DVDSHRINK, file VIDEO_TS.VOB in the VIDEO_TS folder (enter folder with “enter”), both “enter” and “play” start the correct behaviour and menu is displayed and functioning (menu icon is also available pressing “option”).

Well, this could be somewhat more user friendly and consistent…


#3

As has been confirmed by the previous poster you can play any iso (DVD image) and get menus. However you have to enter the VIDEO_TS folder and play from there in order to get menus.


#4

JimKnopf wrote:

…Well, this could be somewhat more user friendly and consistent…

 

Indeed it could, but there are folks that DO NOT want DVD menus, and thus those methods, for now, remain in order to play a DVD without menu interaction. 


#5

@TonyPh12345: Sorry to be contrary to your opinion!

As you can see there are people who expect to see the complete content of  the VIDEO_TS folder and they are confused by the current behavior when hitting the “play” key on the VIDEO_TS folder (and they even invest their time here and ask for help).

It sounds logic and consistent to let the “enter” and “play” key behave the same and so avoid confusion … and for those who want to have a special feature like “skip to main movie directly” I suggest to create another icon in the “option” menu … or to directly create the image containers or  file structures by leaving out menus.

Hope that someone from the development team gets aware of this thread as well.

With thx in advance,

JimKnopf


#6

To go back to the original question. The OP said that he could not find a DVD menu in the new beta release and asked if he was doing something wrong. I believe that no matter how illogical and inconsistent it appears to be, the question has been answered. There is a DVD menu but you have to play the files in a certain way to get it.


#7

Hi all,

thanks for the reply (and the interesting comments). I tried to play on the specific file as suggested… and indeed I got the “menus”… and I can navigate to the various chapters etc. … nice… only problem: now the playback starts to slow down after a couple of seconds (no sound, some kind of slow motion as if the player does not have enough processing power)… I’ve tried a dozen VOBs (which all playback correctly starting the old way by “playing” the video_ts directory… without the menus)and it happens every time

Any more help?

thanks in advance

Sguidati


#8

… just a remark:

thanks in advance for all suggestions to convert to ISO format…

…but I have a lot of files in video_ts format and converting them all to ISO is not an option for me

regards

Sguidati


#9

You could use ImgBurn’s batch functionality to do that if they are one layer. Dunno if Lightning has gotten around to add automatic Layer Breaks though.


#10

@alembic:

No, cannot reproduce your problem. My WD Box is connected to a Panasonic CRT (Cathode Ray Tube) via COMPONENT and using the optical digital audio output via TOSLINK cable. Data sources are on a Synology 107+ NAS connected via Giga-Ethernet switches (but the WD only seems to use 100bt).

Even if I switch from digital to STEREO, I cannot see signs of such a problem symptom you describe although here there could be some more CPU utilization need for the transcode from AC3 to PCM (but perhaps this is done separately in an audio chip).

Could it be that you have a LAN bottleneck between your NAS and WD box and using menus creates some more network IO traffic hitting the bandwidth limit?

Give it a try and place it on a USB HDD or fast pendrive for tests.


#11

Yeah, that’s puzzling, because the bandwidth required for ISO versus playing the exposed VIDEO_TS structure isn’t appreciably different.  It COULD be that the ISO file is less fragmented than the VOBs, but it’d have to be pretty bad to account for that.

Odd.


#12

I am using a Synology 210j connected via Gigabit to the WD TV (as shared network drive not as DLNA server… the DLNA server shows a completely strange behaviour not allowing e.g. simple JPG photo view).

I’ve tried to play via a USB HDD and it works indeed with the menus and without dropout.

seems to be a performance problem when using a network (but thats what the WD TV Live is build for, isn’t it?). Maybe the WD uses another codec when allowing menu interaction. Would be interesting to hear the opinion of a wd firmware developer

anyway, many thanks so far

Sguidati


#13

I think I found the problem …

I deactivated the DLNA server on the Synology and now I have no dropouts when using the menus…

the only problem that arises is that I used the DLNA for music playlist…

…I already have the latest firmware on the synology (and I know that I should ask at the synology forum but maybe someone here has got an idea or experience)…

regards

Sguidati


#14

 ups, the playlist still work (even without the DLNA)…

…so, now I am satisfied!!

thanks again to you all!!!

regards

Sguidati


#15

Wow, that was a fun “Stream of Consciousness” exercise… :wink: