NFS is Slow

Why is it that on the MYBookLive NFS is slow?  I have a GiGE switch and copies from windows are fast.  I would like to use this only for NFS.  

I’ve not seen it be any slower that Samba…  In fact, if anything, it’s a bit faster.

What kind of transfer rates are you seeing with NFS versus Windows copies?

I have done more testing the MyBook is fast when using NFS.  The only time is seems to run slow is when I am using it as an NFS mount for VMware ESX.  I would like to back my environment up to the drive via NFS.  I have tried two different ESX hosts both can copy a 1GB file to my macbook over NFS in about a minute but to the MyBook takes more like 10 minutes.  I realize this might not be a supported configuration but I just can’t understand why this is happening. 

ESX01 ----> 1GB NFS Copy to MacBook hosting NFS ~ 1 Min

ESX02 ----> 1GB NFS Copy to MacBook hosting NFS ~ 1 Min

ESX01 ----> 1GB NFS Copy to MyBook hosting NFS ~ (10 Min)

ESX02 ----> 1GB NFS Copy to MyBook hosting NFS ~ (10 Min)

MyBook ----> 1GB NFS copy to MacBook hosting NFS ~ 1 Min

MacBook —> 1GB NFS copy to MyBook hosting NFS ~ 1 Min

Any ideas are welcome.

We are seeing exaclty the same slowness on ESXi 4.1, data which is being transfered by windows over samba is around 2GB per minute. Any help on this issue greatly received

It’s possible to change the firmware (Debian Linux) to fix the NFS speed problem with VMware ESX/ESXi:

To enable SSH access to the NAS, go to this page: http://your_mbl_address/UI/ssh

  • In the file “/etc/exports”, at the line of the “/nfs” sharing, change the “sync” option to “async” to
      greatly increase the performance of transfer via NFS from ESXi.
  • Reload configurations for the NFS server: /etc/init.d/nfs-kernel-server reload

The reason why the transfer is slow is that the MyBook Live is not a very powerful device and in “sync” NFS mode, it must confirm to the remote host that each block of data has been written to disk, which greatly slows the transfer. By changing the option to “async”, MyBook Live don’t confirms anymore the writing of each packet and is much faster.

This change should persist over time and reboot. Maybe a firmware update will require repeat the procedure.

P. S. Use “nano” as a text editor

Thanks I will test this today.

I wanted to report that after changin the sync to async I was able to run VMs from the sharespace with out issues. There is a huge improvement in the speed and responsiveness.

I tried this on a My Book world and did not work quite as well.

I can tell you that I researched to see if running VMs on a DFS share was possible but everybody was recomending iSCSI instead. I can now tell you that you can run VMs using VMWare from an NFS share.

You will see a huge difference if you change the settings as suggested by CyberSlim

I will be posting how to create and access NFS shares from withing VMWare using sharespace soon.

One more thing,

If you have the NFS mapped on your VMWare ESXI host you may want to remove that first before you do this. Rebooting the Sharespace will cause confilcts on the host and the only way to remove it and re-add it it’s by rebooting the host. If you are running multiple vms this will be a pain.