New WD My Book Essential 3 TB No Longer Spinning Up

Good morning everyone, I’m guessing that this drive is dead but figured that I would post here. WD support is closed until Thursday. Maybe someone here has some advice? Purchased a new WD My Book Essential 3 TB drive a few weeks ago. Purchased to replace an old 1 TB WD My Book. Unboxed, plugged new drive into iMac and connected both the old and new drives to power through a basic interior extension cord. Drives started fine. Partitioned and formatted new drive fine. Reconfigured Time Machine to use new drive for backups. After performing some test Time Machine backups, I was satisfied that the drive was working fine. Unmounted new drive, disconnected from surge bar, plugged directly into wall outlet. Blue power light on the enclosure is lit, but drive did not spin up. Tried pressing, and pressing and holding, power button on rear. Drive still not spinning up. I am disappointed because drive was working correctly for several days, and until I unmounted and unplugged it a few minutes ago. Guessing that problem is with the power button on the rear of the unit. Any thoughts? Is this thing supposed to spin up once I plug it into the USB on my iMac?

You can try with a compatible power supply, call tech support to see if they can get one for you. 

Tried swapping power supplies, no luck. Any other tips? I did open a support case with WD. Let’s see how long they take to respond and let me RMA the device.

When all is shut down, including the Mac, try -

  1. unplugging your Mac and the HDD from the mains,

  2. count to 30

  3. plug everything back in again and restart.  

Does it work okay now?


Did you look for a button craftily hidden button on the rear of the HDD?  If not, and there is indeed a button at the back, press it once.  Did that fix it?