New Release - WD TV Live Firmware Version 1.06.43 (1/17/13)

WD is happy to announce our latest firmware update for the WD TV Live Media Player.

  • Very Important: Rolling back to version 1.05.04 or earlier may break your WDTV.

 You may post your experiences here in this thread.


Youtube Leanback hangs indefinitely at the YouTube-logo&white bar screen when loading. 

(in this latest release, as in every Firmware (beta) version sinds the introduction of Leanback on the Live.

As in: normal, ‘old’ Youtube worked perfectly, Leanback has never gotten beyond the point of just showing the Youtube logo on a black screen)

Please advise on how to solve this, so I can finaly use YouTube(LB)?

My box instructed me to do a firmware update which I did but I have now lost my beloved bbci player :frowning: tried a factory reset in system settings to no avail. Any ideas how I can get it back?

P.s it’s model (wdaap0000nbk) firmware 1.06.43

You obviously were using the public beta release. It appears that the iPlayer did not make it into this update. I can get only suggest that you roll back to the beta release. Update the version number in the ver file of the beta firmware to read say 2.06.43 and save using notepad. This will fool the player into rolling back to the beta firmware.

No problem with YouTube lb loading here. I can only suggest a reset. Settings / System settings / Reset to factory defaults.

richUK wrote:
No problem with YouTube lb loading here. I can only suggest a reset. Settings / System settings / Reset to factory defaults.

thanx for the reply. tried Reseting to factory defaults again (for the first time on this new firmware), no change in situation. Youtube LB still nothing beyond the Youtubelogo&white line. Am I maybe missing something obvious here? Is it a regional thing? Is my device to old for it despite it picking this update by itself?  (I’ve even tried to set it to 720 instead of 1080 for maybe freeing processing powerz) whaaa…  off to bed now, hope that in the mean time anyone in US timezones can think of a solution.

A number of videos from my  Sony NEX-5N camera recorded in AVCHD 1080p 50p format now stutter and lose sound sync with video.

These same videos used to play perfectly with the previous version of firmware(wdtvlive_1.06.15_V)

Please check and re-issue a fix WD

Updated within the last 30 minutes so still have a lot to check out.

All files seem to be playing just fine. No problems with my wired network and connection to Samsung tv.

YouTube Leanback initially hung on the logo screen for >5 min. I unplugged the device, plugged it back in and it logged in fine without stalling.

Network Shares seem to work as they did before. I was able to cause a reboot when I scrolled through a large network folder too quickly.

Thanks for the update Bill and WD.  I’ll update my Live Plus tomorrow and report it in the other thread.

I upgraded to the new firmware and after a short tryout, things seem to be fairly stable and working well. Have not tried all options yet though. 

Some new things that work now (on the WD TV Live):

  1. Youtube Leanback

  2. My youtube (I never could sign in into my WD TV live previously after many different attempts). Now sign-in works first time and allows me view the youtube subscriptions. 

  3. Not sure if this was there in the prev firmware, but I can view HD videos in Youtube now.

  4. Youtube pairing to mobile (tried with a Android phone)

  5. Android remote app (had a hard time getting the app to recognize my WDTV Live. Changed a setting on my Dlink AP and finally had this working).

Good job WD and thanks Bill.

1 Like

THank you for this update, everything is working fine.

Is there any chance that I can play divxformat movies in the future or do I have to convert to another format.

After I updated, it won’t pay AVI files over my network share any more. I can fast forward and rewind the file but pressing play seems to perpetually pause the video. MP4 and MKV files seem to play fine. 

I have only ever played files over my network share and the new update seems to have broken something. I tried resetting to factory defaults without any luck. 

Thank you for the new update! (At last…)

The firmware works beautifully…

I see that the fast-forward function for video is much smoother now (The first noticeable difference before and after) and FINALLY…the youtube problems are fixed! Thank you. 

p/s: Any chance of having Vimeo on WDTV Live in the next firmware release please?


Yes, also very concerned about loss of iPlayer!!! (I am a UK resident). I also noticed that when the iplayer was functional on the previous firmware, it would always cut off just before the end of the programme…

wd563 wrote:

Yes, also very concerned about loss of iPlayer!!! (I am a UK resident). I also noticed that when the iplayer was functional on the previous firmware, it would always cut off just before the end of the programme…

WD know about the cutting off they just seem to have a problem in actually fixing it. If you want the iPlayer then you will have to go back to the public beta release.

Since performing this upgrade late last night I am no longer able to connect to the internet.  The wireless adapter still seems to be working fine because it can detect my router, reports back when I enter the encryption password wrong, etc.

From the router side of things I can see the WDTV as a connected device.  The WDTV doesn’t seem to think it is connected though.

I’m guessing the problem is when the WDTV attempts to obtain an IP address.  The error constantly says “Unable to obtain IP, check your connection settings”.

The error is present regardless of whether I use the Automatic/Fixed method for getting the network settings.  In using the fixed method I tried assigning a fixed IP address on the router and on the device…even this didn’t work.

This was definitely working prior to the upgrade because I wouldn’t have even known about the upgrade if the device hadn’t been connected to the internet.

Anyone have any advice?

Network shares still a problem, now cannot get past invalid user/password screen. Cleared network settings, reset network etc etc and still no joy.
I have one xp machine on network with no login security.

Where the devil has the BBC iplayer gone, one feature that more or less worked properly (except early ending, which I believe to be a BBC issue as the application is loaded remotely every time you log in and this allows BBC to update the iplayer independently of WD). It was available in the last full release and following beta.

As networks shares are the same or worse and no iplayer I will revert to the beta release.

After updating I can no longer play MP3 files on my Synology DiskStation.

After the update when I access my audio file folder the WD TV Live says:

“There is no media in the current folder.”

Any idea how to fix this?

On this release rapid/fast moving changes in pictures make the playback (video and sound) stutter, and it does not recover even when the picture stops until you pause and play. 

A good example is the opening credits to the Big Bang Theory. When the picture starts speeding up, it refuses to play properly any more, and when the credits are done you have to pause/play to get it to play again properly. 

Very disappointing as this was fine before the update. 

Oh noooo! Don’t tell me that the new firmware still don’t support 3TB HDDs.
1.05.04 was the only version that recognized my 3 TB HDD.
That’s very dissapointing. Can someone confirm this?

So the WDTV is useless for me :frowning: