Version 1.06.3

I am a newbie.  I, as all of us have, paid good money for this WDTV Live box.  I have taken so many knock out blows from WD and have reeled around, smashed everything in my way because of frustration and finally after being on the floor for hours in a pool of blood, picked up me pen and started to write about a part of these awful years with this WDTV box.

Lets start here, last December 2012 I think, with Version 1.06.34 I lost youtube and got the lean back you tube and that has never worked properly (its was sooo slowww), I was unable to access my NAS drives and a whole load of other issues.  But, on the only plus side we had iplayer.

Then the other day we got 1.06.43 and some light fingered fool (me) downloaded it thinkling all those issues would be fixed, instead we have worse network issues, it takes about 2 hours to connect to my local shared drives, usb drives take about 3 minutes and the wireless keyboard drops characters. Iplayer has gone completely and leanback search is just that.

i KNOW THIS MIGHT SOUND REALLY DUMB, but can anybody give me the link to the 1.06.34 firmware I was happy with that I think, even though it was totally [Deleted] from my 1.04.** Version I used for yonks!

One other thing is there any mileage in downloading firmware to a usb stick, then updating so that iplayer will work, WDTV box assumes its not in the UK in this mode?

If anybody out there has a better idea please let me know I am at my wits end with this thing that called WD.



PS. suicide will not be considered.

For some unknown reason WD removed iPlayer from the latest release and no matter how you install it there will go no iplayer.

Ok thanks for that richUK,

Do you have any ideas how I can go about getting a firmware version of 1.06.34 or is there a better way out of my main dilemma?


You could try 1.06.41 as mentioned in my post.

1 Like

I suppose, in theory, it could be better than 1.06.34 and maybe iplayer will work too?

shall try that later today now…


After reading about firmware version 1.06.41 I have decided to chicken out and really need to go back to 1.06.34.

Can someone please tell me where the WD link is for firmware version 1.06.34?

What is most annoying about the WD site is that I cannot find any firmware versions pre 1.06.41 beta, what does it cost them to leave it there after they have b*****d up their latest version.  What’s 80Mb of data these days?  (and they give disclaimers anyway!!!)

Incidentally all I could find is (528Mb), there are loads of these GPL code packages what are they for, what do they do?


PS. bought a new wood burner recently if the price of electricity goes up much more (and of course WD can’t GTAT) it will become most cost effective to put it on the hot embers:neutral_face:

Why have you chickened out of 1.06.41 when WD actually pulled 1.06.34 because of problems. WD has no downlink because they don’t want it used.

GPL packages are not to be used, they are there as a legal obligation due to the WD firmware using certain opensource coding.

The reason I want to go back to 1.06.34 is because it worked better than 1.06.43 for me and 1.06.41beta is an unknown. 

Also, I am wary because I don’t want to F it all up for grandpa who as a refugee listens to radio in his language and watches thousands of pictures of his past life on wide screen HDTV, when he was a much happier man!  To go on would be a travesty to this sites pages and not required.

Anyway, from reading what others say, when rolling back, it appears there is less trauma when rolling back to the previous firmware used. I think 1.06.34 had the old style youtube as well, or was that the one before, can’t remember anymore.


Well, daftly, after a lot of thought decided to install 1.06.41beta and as I feared it is worse than 1.06.34 (and 1.06.43).  As you may recall from above I had issues with my NAS drive, but could access all the shared drives on my PC’s and MAC’s including their USB drives on 1.06.34.

With 1.06.41 I cannot access any network drives or media servers, the wireless keyboard drops characters.

The only plus is that there is HD available on youtube leanback, radio, weather (no sat map) and iplayer - can’t access any media from my network drives or media servers.  At least before (1.06.34) my drives and servers would connect after 2 hours.

Rich, do you by any chance work for WD?

Has anybody got any advice on how I might get back to 1.06.34 or this thing working without me going off to B-RAD, I am told his 3rd party ware will allow me to access all my drives?


TheBeeMan wrote:

Has anybody got any advice on how I might get back to 1.06.34

Usually you’d do it like this but since the 1.06.34 is withdrawn you need to find it via Google.

No I don’t work for WD. I said to use that firmware because you were moaning about losing iPlayer and that firmware was the only way to easily get it back.

You may get 1.06.34 at the forums below but you must register first. If that does not work don’t blame me because I don’t work for them either!

I’m not sure that b’rad can give you the iPlayer so make sure of what you want before jumping into various firmwares and then being disappointed.

Sorry richUK - bout working for WD - but their money would be nice wouldn’t it!?

iplayer was a little moan, but I would rather have the old youtube than iplayer and of course access to my network.

I’m registered with that forum, but they have withdrawn 1.06.34  a while ago, I think within the week of it going live (not sure)

Do you or anyone out there have a copy that I could have?:smiley:


Good News,:smiley:

Today for some unknown reason my Network Shares appeared, I just don’t know why, also, last night my Media Servers appeared again don’t know why but, my NAS drive is still out, that’s an Iomega 350MB unit?

During the week I have turned off the box every night, and on Thursday night I disconnected the box completely.  I even contemplated the master reset with a paper clip at one stage. 

:confounded:There is one down side tho and that is I cannot get my wireless keyboard to work, has anybody got any ideas as to how I can get this back?

I’ve tried disco kybd by unplugging dongle and changing keyboard batteries.  When I installed it yonks ago, I just plugged in dongle and it worked first time.

One other niggle, when using youtube can’t play any Eddy Grant stuff except some of his concerts what’s all that about?  They’re not in HD and this same scenario happened way back in firmware history, OK HD never worked til recently, but how come HD won’t play.  Ah its not limited to Mr. Grant this is just an example because most won’t play.