New Release - My Cloud Firmware Versions 2.31.163 (01/08/2019)

Be careful this new firmware disabled your ssh, and doesn’t possible enable again. Secure issues :frowning:

1 Like

Same for me, automatic update is not finding the firm and Im not sure to make the manual update really…

I found that, WD cloud desktop for window cannot be use anymore after the firmware upgrade.

Others have complained about that issue of the Desktop program not working after updating to the latest firmware. Bottom line is, unfortunately, WD Desktop has been end of life for a while now (couple of years). It appears WD wants we users to use MyCloud.com/

The WD cloud desktop app for windows did allow me to login, it finds my drive but then says that it has an error connecting, gives another login prompt without the ability to type in a user id and does not recognize my password, then it shows that it finds my drive on the network, and repeat same error.
I really wish they would support this app it worked great previously and faster than using an old internet explorer program since it’s not compatible with Microsoft Edge.

The WD Desktop software if end of life, WD apparently won’t support it any more.

The workaround is to use a supported web browser with the MyCloud.com web portal.

MyCloud.com supports the following web browsers:

  • Internet Explorer
    
  • FireFox
    
  • Safari
    
  • Google Chrome

Hi,

I am on firmaware 2.30.181 (2.Gen. device) and my desktop app on Windows 7 works. I can login and access my files? Why?

My current firmware is 2.30.181. Check for Updates said that “The My Cloud system firmware is up to date.”
so, from now, WD decide to use manual download for update firmware?

I had a message to update but now it tells me it is up to date. Still running 2.30.165.

I am trying to download this but it leads me to firmware 2.31.174. I need to downgrade my firmware as my remote backup is no longer working after the update 2.31.174 and 2.31.183

This is the screenshot after clicking the link above.

The following link has some information, and prior firmware links, for downgrading the firmware on single bay My Cloud models.

Will this work in MyCloud Ultra EX 2?

Hi, if I update My cloud with a firmware earlier than 2.30.196, the My Cloud desktop application ver. 1.0.7.17 will not connect anymore. Any idea why? Have a good day!

See the following WD Knowdgebase article. The WD Desktop program has been end of life since 2016.

https://support-en.wd.com/app/answers/detail/a_id/25159

Hi Bennor, I think its a sad thing that WD abandonned the desktop application. I find it is a more usefull and much easier link sharing application than the web application. I will thus maintain, as long as I can, the older myCloud firmware so I can keep using the desktop application, hoping WD eventually changes there mind and offers an updated desktop application. Thanks for your time and have a good day!

Is there really no way to re-enable SSH with this update?? I guess I will never update then since that makes the device useless for me.

Last night my office’s DL4100 updated firmware, and since this morning the power light has been flashing blue and all disk lights steady blue… it has 16 TB disk space, but only about 4 TB data. I’m worried it will take 7 days… several of my colleagues are desperate to retrieve their data!

what is the problem with the SSH? Why re-enable it? Last time is turned off the device via SSH successfully