New Release - My Cloud Firmware Versions 2.31.149 (10/19/18)


#1

WD is happy to announce the release of My Cloud Firmware 2.31.149 for manual download at https://support.wdc.com for the following My Cloud products.

· My Cloud
· My Cloud Mirror Gen2
· My Cloud EX2 Ultra
· My Cloud EX2100
· My Cloud EX4100
· My Cloud DL2100
· My Cloud DL4100
· My Cloud PR2100
· My Cloud PR4100

What’s new?

Security Fixes

• Resolved multiple command injection vulnerabilities including CVE-2016-10108 and CVE 2016-10107.
• Resolved multiple cross site request forgery (CSRF) vulnerabilities.
• Resolved a Linux kernel Dirty Cow vulnerability (CVE-2016-5195).
• Resolved multiple denial-of-service vulnerabilities.
• Improved security by disabling SSH shadow information.
• Resolved a buffer overflow issue that could lead to unauthenticated access.
• Resolved a click-jacking vulnerability in the web interface.
• Resolved multiple security issues in the Webfile viewer on-device app.
• Improved the security of volume mount options.
• Resolved multiple security issues in the EULA onboarding flow.
• Resolved leakage of debug messages in the web interface.
• Improved credential handling for the remote MyCloud-to-MyCloud backup feature.
• Improved credential handling for upload-logs-to-support option.

Components Updated

• Apache -v2.4.34
• PHP -v5.4.45
• OpenSSH -v7.5p1
• OpenSSL -v1.0.1u
• libupnp -v1.6.25 (CVE-2012-5958)
• jQuery -v3.3.1 (CVE-2010-5312)

Other Bug Fixes

• Resolved high CPU utilization with ufraw-batch process.
• Improved remote host port handling


#2

#3

Hello
how do I install the new firmware?
The dashboard does not work after login.


#4

When I click on Firmware Update from Settings within http://mycloudex2ultra.local/ it tells me my Firmware is up to date though the version is .30.196 updated on Saturday, 2018 September 29
Do I need to download the file and use the manual update, or should I wait for it to pull the update?


#5

We have the same behavior on EX2 Ultra running 2.30.196, the message is “The My Cloud system firmware is up to date.” Do we wait for the auto-update to pull or do we manually install?


#6

I have missed a couple firmware updates for My Cloud Mirror Gen2. Do I need to install each missed update in order of release or does the latest version incorporate the earlier fixes/improvements?
Thanks


#7

WD MyCloud App for Mac stopped working after the update. How do I roll back the firmware?


#8

DO NOT UPGRADE TO THIS FIRMWARE VERSION IF YOU’RE BACKING UP TO A LOCKED MYBOOK!

If you back your NAS up to a MyBook, you very likely have the MyBook locked using WD Security, and then you unlock it using the NAS GUI when you need to back up. That functionality no longer works in this firmware version. I tried calling WD and spoke to Max over in India who told me there was nothing I could do and that the firmware could not be rolled back. Then I got an email a day later wanting to know if the issue was fixed. Seriously???

Fortunately Max didn’t know what he was talking about. Thankfully k_unc posted a link for the old firmware. You may find it here:

http://download.wdc.com/nas/My_Cloud_BVBZ_2.30.196.bin

After rolling back the upgrade we were able to back up to the MyBook again.

If you want to turn off the annoying Firmware Upgrade nag emails you can do that under Settings > Notifications and then either turn them off, or change it using the slider so that it only notifies you for real issues. We’ll likely never take another firmware update.