New Release - My Cloud Firmware Version 04.05.00-334 (03/12/2019)

WD is happy to announce the release of My Cloud Firmware 04.05.00-334 for manual download at for the following My Cloud products.

My Cloud (single bay with 04.xx.xx-xxx firmware code line)

04.05.00-334 Release Notes

  • Security Fixes
    • Resolved security vulnerability (CVE-2018-1160) - Netatalk Arbitrary Code Execution Vulnerability.
    • Resolved Samba security vulnerability (CVE-2017-7494).
    • Resolved multiple command injection vulnerabilities including CVE-2016-10108 and CVE 201610107.
    • Resolved multiple cross site request forgery (CSRF) vulnerabilities.
    • Improved the security of volume mount options.
  • Components Updated
    • Apache - v2.4.10
    • OpenSSL - v1.0.1t
    • libupnp - v1.6.25 (CVE-2012-5958)
  • Other Bug Fixes
    • Improved remote host port handling.
    • Resolved USB drive unlocking mechanism.

Manual install of downloaded firmware worked fine.

No problems found yet, barring the usual one of reverting any manual tweaks that have been made via SSH.

How is sleeping time?

What version of vfs_fruit (the AAPL extension to SMB2) is included in this release? I downloaded the GPL source code, but there was no vfs_fruit man page. smbd -b does show that the module was built it to smbd.


I’m trying to download the latest firmware, but I think that the link is broken. Can help me someone?

That is the GPL source code link for one to build their own firmware for the My Cloud. If one wants the actual firmware link for the DEB file that they would use to manually update their first gen My Cloud, use the link below:

1 Like

After updating to the new firmware I seem to have lost the ability to browse content via DLNA. Dashboard shows plenty of videos and music but DLNA Media quantities show Music Tracks: 0 Pictures: 0 Videos: 0. I have restarted the box, performed a rescan and rebuild but they still show 0. Can browse to the files via network shares but not much use on my TV!

Access the Twonky Administration page (usually http://wdmycloud:9000) and go to the Advanced page and select the following buttons at the bottom of the page in the following order, waiting a couple of minutes between each button select: Clear Cache , Reset to Defaults , Rescan Content Folders. Then see if you can see your media using your DLNA client.

For DLNA to work on the My Cloud one has to enable Media Serving on each Share that contains media.

this firmware repear problem missing disk on network?

Thanks for you help Bennor. I tried those steps without success so ended up resetting the system only and reconfiguring the box. Had to re-enable media serving on each share as you suggested and now all back up and running again.

Just installedMy Cloud Ex2 Ultra on 5/26/2019. I see this is a Manual Download.
On the dashboard, Firmware - my version is 2.31.183 - the button reports this is the latest version.
Do I need to manually download the new Firmware or has my dashboard tool kept me up to date.

The 4.x firmware is for the old first generation single bay My Cloud and no other devices. The 2.x is for the second generation single bay My Cloud and the multi bay My Cloud models.

Yes it’s stupid WD used the naming convention they did as it’s routinely caused people to assume the v4.x firmware is newer than the v2.x firmware.

How do you know what generation device you have? I got a used single-bay MyCloud from a friend and it says it has v03.03.01-156 (last updated Dec 2013), when I click the update button it says it has the latest?

Never mind - I found the release document
and it shows that v03.03.01-156 is a predecessor to v04.05.xx

Hi, mine is still updating, after almost 3-4 days now. blue led keeps flashing and i cannot access the device , do you have any solutions for this ?

Power cycle and try again

this is all peachy keen and sweet. how about lets get right to the point for us wanna be peter geniuses . Like we spent almost $300dollars for this pile of paperweight too. what is the pet file? with? you mean to tell me you can not make it more simple than this? I already have more hours trying to get this hunk a junk to even work now to add more to it and more work? I don’t work for you nor do I get paid from you. I DID however pay an enormous amount of money for a pile of junk with your name on it. kindly get me updated…ty. MPM


Hi everyone.

I updated to firmware 04.05.00-334 and the unit is presenting random disconnections. It does not appear as a network drive, and the GUI cannot be accessed.
This happens randomly during file sharing or when trying to open a folder on the drive.
After a few minutes the unit is again present in the network and so on.
The unit has its own IP address assigned manually to ensure there is no conflict of ip, all configured correctly. Its a WD My Cloud 3Tb first Gen.

Any idea what could be happening?