New Release - Firmware Version 3.10.09 for WD TV Live Hub (2/27/13)

WD is happy to announce our latest firmware update for the WD TV Live Hub Media Player.

If you experience any issues with this firmware, please report them in the WD TV Live Hub Issue Reporting exchange.

Feel free to post your questions or experiences in this thread.

Thank you :wink:

All done, updated via Internet and everything still working.

Just noticed Auto Power Off after 3hrs inactivity feature ( under Settings/Operations ) … excellent :slight_smile:

Update went fine no new ssues here.

I had to re-enter my VUDU account information , no biggie

Still having an issue with my folder.jpg not appearing. I have a folder for Movies and TV Shows and a folder.jpg in each of these folders and the only one that doesn’t show up is the one in the movies folder. I have replaced the .jpg with the same one that works in the TV Shows folder but it still doesn’t show up. It shows the metathumb for the first movie in the movie folder, so i have to rename my folder.jpg to AAfolder.metathumb and then it shows up. The update didn’t fix this issue.

I have several MKV files i’ve rippped from my discs and they all play except 1 and was hoping this update may

address that but this update only addressed other file format playback issues. Here is a link to the movie’s


Resolved FLAC incompatibility issue.

Can someone give me more info about this specific incompatibility issue?

Oh, did’nt see this firmware update :neutral_face:


FLAC (5.1 Channels)  where incorrectly assigned to the wrong channels / speaker alginment

eg. ‘front left’  was ‘center’ etc

1 Like

TV Shows are still being sorted wrong. Here is what happens:

After the content was tagged with the so called ‘content info’, the sorting isn’t very user friendly (but still logical). It sorts it like this:

Episode 1
Episode 10
Episode 11

Episode 2
Episode 20
Episode 21

Episode 3

Again, I totally see why the OS sorts the data like this, but for a media center this is not user friendly at all. Are there any fixes planned or workarounds?

An easy fix would be to still sort tagged episodes by their filenames instead of the new tagged content title.

A fix for this issue was announced in 3.09.18 (Resolved TV Shows content info is incorrectly sorted.), but nothing changed!

Please fix this.

AndyAgain wrote:

TV Shows are still being sorted wrong. 

As has been explained numerous times, using the FOLDER filter, files are sorted purely alphabetically by TITLE.

If you want proper TV show aggregation, use the TV SHOW filter.

Why no update on YUPPTV  issue, its not been working sine appeared in WD TV LIVE HUB services,

extremly dissappointed with WD. YUPPTV is the only reason to buy this player.


I have a question, should I download all firmware updates or only the latest ?

Will the latest firmware update replace the previous one ?

Hello Chandu,

In order for us to effectively review the issue you are experiencing with your WD TV, can you please asnwer the following questions below? 

- Which firmware?  3.10.09
- What happened?
- What were you doing?
- Does this happen every time?
- What hardware and media were you using?
- Did this happen with previous firmware?
- Does power cycling the unit solve this?
- Does resetting to factory defaults solve this?
- Have you tried this on other devices?

My wdtv is screwed now after this update. Its stuck on the wdtv live hub screen saying loading and the light on the front of the unit flashes. I cannot see the internal hard drive on my network any more :frowning:

I have tried resetting and powering on and off the unit but I cant even roll back the firmware as I cant get to this screen.

Kicked me out of Netflix and unable to log back in!

I can’t get into Netflix either., have two buttons “Try Again” and “Exit” and to visit yet my internet connection passes on the hub and i can access my Netflix via my DVD player so it’s not an account issue.

Aside from being bumped out and couldn’t log back in. The new FW still has the ‘sticky’ subtitles when viewing Netflix streaming. I’m rolling back to 3.0.6.

Yes I am also getting same error when trying to get to Netflix

I rolled back to 3.0.6 and the Netflix error is stuck with the old fw. Can’t log in! All the while Netflix works normally through my TV but ot seemed like this new FW had corrupted my device.

Hi - are there any plans to support CEC on this?  I thought I read somewhere that CEC is supported on the WD TV Live and was hoping to get that supported on the Hub as well.


sanisan wrote:

Hi - are there any plans to support CEC on this?  I thought I read somewhere that CEC is supported on the WD TV Live and was hoping to get that supported on the Hub as well.



It’s been supported for a long time.

I have fixed my stuck on the wdtv load screen with loading… continiously:

1.opened up wdtv ie took lid off from the corner round with a knife

2 took out the hard drive easy 1 screw then carefully pull out the drive.

3 attached the drive to my windows 7 PC via a sata usb dock

4 a message came up saying do you want to fix drive errors so i clicked yes and within seconds it said ok fixed.

5 went onto the partition where my media was stored and deleted the wdtv folder and microcache folder.

6 ejected the harddrive correctly from pC

7 put the drive back into the hub and lid back on hub

8 plugged it in and voila loaded straight away :slight_smile:

Im happy at least firmware read the latest as well.

hope this helps someone else