New Release - Firmware Version 3.09.18 for WD TV Live Hub (1/24/13)

WD is happy to announce our latest firmware update for the WD TV Live Hub Media Player.

If you experience any issues with this firmware, please report them in the WD TV Live Hub Issue Reporting exchange.

Feel free to post your questions or experiences in this thread.


Nice update. may have to go back to XMLs just for the movie filter. :wink:

Bill - Is there ever going to be an option to show artwork for the Main drive and attached drives to the Hub, it’s the only thing that looks bad on the screen. I can have all my other folders/shares looking as I want, but having generic artwork for the drives is just plain ugly ?

I don’t know, but I doubt it.  Isn’t all that part of the Mochi theme, as it is, or is it separate?

The “generic artwork” is part of the theme.

But the requirement to DISPLAY the generic artwork is part of the firmware.

Like wdtvhub says, it’s really a glaring omission that the internal drive and any USB drive can’t have folder covers, but all NAS shares can.

Resolved TV Shows content info is incorrectly sorted.>  > yeah right :(> if that were true then S03E02 would list before S03E11

1 Like

All updated ( via the net ) in under 7mins … everything still working … will post back if any issues :slight_smile:

Still no thumbs for movies if they are video_ts.   I have pretty much given up on this ever getting fixed.   Considering going to .m4v to save some space, think I figured out how to get subtites which is really the only think I kept the full dvd rip for anyway.  c’est la vie, other wise things seems to be going well with the update, no issues loading the new fw (hard wired enet connection, never really have issues)  things seem pretty snappy.   

’ Resolved long Blu-Ray ISO video loading time.’

Does the player now support playback of Blu-Ray ISO’s now? Seemed like I tried this a while back and they didn’t always start at the beginning of the movie. Thats the reason I started ripping to M2TS or MKV.

Thanks, John

I havnet done video t’s in awhile but the folder that has them in it you can name the thumb .folder and it should show and I think eons ago the firmware allowed you to just hit the folder that the t’s were in and it would play. Sorry if I am wrong as I have not done this in ages I went to iso files it was so much easier to deal with

Just finished updating to the new 3.09 FW and everything seems to work fine BUT it still suffers from ‘sticky’ subtitltes on Netflix playback. The problem started after 3.06. and after subsequent updates. I went back to 3.06 because of the reason until now. Regular Video_TS subtitles seemed to initiate with a delay, and when switching to different languages. So far so good except for the reasons noted above.

May want to wait on this one.  After update if previously playable .avi file is started and the player does not play it, no further playing of .avi files is possible without a system reboot.  This is the same if the file is started on a windows shares or local drive.  I have not attempted to download and install via USB but I may have to see if I have to fool the system into thinking it has an older FW.  So far it appears that my problem may be unique and I hope it is, but it will not address my current problem.

Yes, there are workarounds to the issue.   Its a pain in the butt, and isn’t ideal.  The thumb shows with the little folder icon superimposed on it.    I am trying NOT to hack around issues on this machine,  for family use it needs to work out of the box.   The hub recognizes the content as a specific movie, dloads info an images, but does not properly use them for video ts’s.   It is irritating.

It’s wonderful to see a new firmware release, especially with the long list of bugs that have apparently been addressed.  One question though…

I don’t see any mention of the Component Video bug that’s been around since after 3.0.28…  Has it been fixed with this release?

Update…flashed back to earlier FW and issue was still present.  This leads me to believe that the .avi file is the culprit.  Reflashed to 3.09.18 and all is well so far.  I could not believe that I had not played the suspect file previously, but it appears that I may have well not played it.  Oh well.  I would suggest that all flashing of firmware be done with a flash drive.  Have both the new and flash back files in separate directories with the files you wish to flash in the root directory.  This way you can cut and paste your way away from frustration.

I gave it a brief test run and this seems to be the best update since ever :slight_smile:

Good Job Bill

Posted a new firmware issue reporting regarding the sticky Netflix subtitles.

I applied the new firmware last night and then promptly regretted doing so.  After the download and reboot, I would see the initial WD splash screen for a few seconds and then it would go black and the display were never come back.  After multiple reboots (each time waiting 15+ minutes) and doing a reset back to factory defaults with the button on the bottom of the unit, it still behaved the same.  It wasn’t until I found and hooked up an old component cable that I was able to see the Menu again.  The HDMI output stopped working.  I then tried manually setting several different HDMI resolutions, but I could never get it to work.  I eventually did a firmware rollback which fixed my issue. 

This is the first time I’ve encountered such a serious functional issue with any of the firmware updates.

Just my Experience…

Updated to Firmware 3.09.18 … No Problems with HDMI (Picture and Sound OK)

The XML files content has changed - NO & tags. I would edit the XML file to adjust the Cover Art to a tag that was the right language or to insert tags to add Cover Art (pointing to my own server) for those TV Shows and Movies that did not have them.

Did notice that the new XML files have Carrage Returns at the end of tag sets - thanks.

I have developed a Web Based Application using PHP that parses the XML files and display a Nice formatted

output that can be saved as html to show the “Inventory” of what is on my Hub without using a TV.

Without the former XML tags this makes any development to parse the data from the XML files useless. I updated my PHP code to use the 's - but these images are wide-screen.

So you don’t know what firmware you are on, but someone has gave you it for Beta testing…beta testing what?

It sounds to me that you need to read the manual, or stop drinking. :slight_smile:

You trying to say WD gave you a Live Hub with a firmware that has never existed, but we are at 3.XXX XXX and you can’t upgrade to test it.

Haha best post I’ve seen on here !