New Release - Firmware Version 2.31.08 for the My Book Live Duo (5/30/12)

WD is happy to announce the release of its firmware update for the My Book Live Duo.  Feel free to post your experiences in this thread.

update fast and smooth, 8min 32sec

If anyone starts the update then gets an error to then be returned back to the Dashboard UI, observe the activity LED of the MBLD.  If it is yellow (or maybe Purple?) then chances are the update is in progress BUT the Dashboard UI indicates that the update is not happening. Wait for a minimum of 20 minutes.  Don’t log-out of the Dashboard UI.  Just close the browser and leave it alone. If you have SSH enabled then the update processes can be confirmed using the command:  ps -AFH

Here are the problems i faced and what all i could fix.

First of all I could not access dashboard. I tried everything

1 Using WD SmartWare

2 Going through network

3 Directly entering IP address

All browsers could not find the page. I was connected to the internet and could access all websites. Also WD smartware icon in the tray was showing usage as 0% and temperature unknown.  I updated the WD Smartware. Restarted both the laptop and the PC and EUREKA. It started working.

Then when i started upgrading from the dashboard I used the file provided and there was an error message and the WDMBLD had a continuous purple light. Did not bother finding out what it was. I basically did the same thing again. This time staring at the laptop screen to see where the problem could arise.

Needless to say this time it just worked fine. The NAS automatically  rebooted and now i have flashing green. (so glad i did not lose my data).

I have not really explored the small details of the upgrade but I am happy to report one of the things which had haunted me since i bought the disc has been resolved. My PS3 is now detecting the WD Media server and it has a new icon. Thanks Team WD.

it has been about 2hours since the update, in process of checking anomaly of kind

  1. light blinking (green) and not going (neon blue) stand by. assuming hard drive active

  2. Media fines started with zero count, assuming rescanning. (setting>media>status)

  3. Hotter than normal, possibly due to hard drive continious scan

Dear WD,

Firmware updated smoothly and has fixed MKV support with Samsung TV with no doubt, but I still can’t have subtitles and I can’t change Audio Languages, even if I click on tools in my samsung remote, I don’t see any of these options. please confirm if its still issue with your DLNA Server ?

because I’ve tested on SERVIIO and it works fine with TV for subtitles and Languages.

2ndly , I would like to know that if there is any chance of having 1x/10x/20x FF/RW and Scene selection option in future updates for DLNA Server ? we can use these options while connected to USB but can’t use them on NAS.

Prompt reply would really be appreciated.  Thankyou

I don’t know if this will help anyone, but I tried to update the firmware this morning using Firefox as my browser. I received loads of errors namely: 30088, 31105 and 31118. In each instance the update was unsuccessful.

I then opened Safari and logged onto the UI, ran the update and it was successful first time of asking.

1 Like

I have Logitech Media Server (LMS) running on my MBLD as well as some cron tasks.  

Will I have to reinstall LMS and reconfigure crontab after the firmware update?

How did you get LMS to run on the DUO?  Do you have a guide or link i could use for reference?

  I have a couple of squeezebox devices and would like to run them from the Duo.

After some light testing - and assuming that the update overwrote the version of forked-daapd I installed - the following issue seems to be fixed:

So “Resolved issue of degraded performance on music playback using iTunes.” — ticked :slight_smile:


PS: Next issue on this area is the pairing of the iTunes remote apps. :wink:

theos2 wrote:

How did you get LMS to run on the DUO?  Do you have a guide or link i could use for reference?

There is a long thread on the Squeezebox Forum for My Book Live.  I summarized what I did for my Live Duo in post #129.

It works great!


update failed, wasted hours of retry… Always goes like this :

root     24174     1  0    79  2752   0 08:57 ?        00:00:00   /bin/bash /usr/local/sbin/ /CacheVolume/ap2
root     24207 24174  6   163  8512   0 08:57 ?        00:00:02     dpkg -i /CacheVolume/ap2nc-023108-067-20120515.deb
root     24375 24207  0    65  1792   0 08:58 ?        00:00:00       dpkg-deb --fsys-tarfile /CacheVolume/ap2nc-023108-067-20120515.d
root     24377 24375  2    65  1792   0 08:58 ?        00:00:00         dpkg-deb --fsys-tarfile /CacheVolume/ap2nc-023108-067-20120515
root     24378 24375 61    64  2496   0 08:58 ?        00:00:14         xz -dc --format=lzma
root     24208 24174  0    56  1472   0 08:57 ?        00:00:00     tee /CacheVolume/update.log
root     24374     1  0    80  2176   0 08:58 ?        00:00:00   /bin/bash /var/lib/dpkg/ upgrade 02.31.08-067
root     24497 24374  0    61  1856   0 08:58 ?        00:00:00     sleep 10

then it stops with error message 31105.  Same when I try to install it by seeking/downloading…

What’s wrong?

Edited: found solution myself: some files due to be overwritten where read-only, I don’t know how this could happen…
I put them to 755 …and then it went…

Best regards

Peter C.

After 2 days of successfully showing up on the PS3 suddenly (without any changes) the wd media server is not shown again… :manfrustrated: 

I can still view all files through the other media servers. And can access the NAS on my laptop.

I have had similar issues with my 6TB version.  I hope someone can offer some help.

Problem: Drive shows up on my Mac and Windows 7 laptop and I can read/write/stream to them but does not show up on my PS3 or Xbox.

  • Media streaming is enabled in the Duo’s UI and shows the PS3’s ip and lists it as a generic media server.
  • A rescan of the media is ongoing (days) and still only shows at 8 video files no pics, no music.
  • I currently have 400+ videos, 9000+ photos and 4000+ music tracks on the Duo.
  • All have been placed in the ‘pre-setup’ public shares, no new shares have been created.
  • I am using Raid1 format.
  • The latest firmware has been applied to the Duo.
  • I can access all files from the WD 2go app on my Ipad (works very well) and all pic’s from the WD photo app on my android phone which both appear to work locally and via the internet.
  • PS3 has ‘Media Server Connection’ Enabled in network settings.
  • PS3 is hard-wired to my router as is the Duo.
  • The Duo is seen on the PS3 after a rescan of the media servers on the Duo (and PS3) but is not accessible.  It then disappears shortly after.
  • [EDIT] SmartWare on my windows laptop only shows the Duo intermittently.

I would be happy if I could sort out the PS3 issue, not so worried about the xbox just yet.

Thanks in advance.


Subtitles are not working for neither .avi or .mkv file types.

Thank you in advance for any suggestions you may have!

Hi there, 

I just tried to install this upgrade to my brand new My Bool Live Duo 6 TB. 

Using automatic upgrade, I got some file copying errors during upgrade and the upgrade fails. 

Same for manual upgrade over the gui. 

When trying to do the update using SSH, i get the expected output


  • but nothing happens after that. 

Actually, I now have a LED blue mixed with red (?) and nothing happens. 

What should I do? 

Regards, dante_hd

PaulBC wrote:

I have Logitech Media Server (LMS) running on my MBLD as well as some cron tasks.  


Will I have to reinstall LMS and reconfigure crontab after the firmware update?

To answer my own questions, yes, and yes.

I had no problems with the firmware update, and had LMS reinstalled and my cron jobs reconfigured within an hour.

I would be interested to know where and what files you needed to set to 755. Thank you! (this is in regards to Peter C.'s response. This forum doesn’t seem to function like most others.)

are you still able to SSH ?

if yes, after you used the update command, you can see status of update with the following


ssh window is not like GUI to show current status, you need to run the above command each time you help want to see the status which is from 0-100% , takes about 8-12mins usually for complete upgrade.

hope it helps .

1 Like

Hi there, 

thanks for the information! 

I will test this tomorrow, actuall I was able to get the LED to green by rebooting using the GUI. But: The update still is not installed. 

I guess, the update fails because some files need to be 775 but are not.