New Release - My Book Live Duo Firmware Version 2.40.06-048 (12/17/2012)

WD is happy to announce the release of its firmware update for the My Book Live Duo.  Feel free to post your experiences in this thread.

NOTE: After updating your device, the updated DLNA® media server will rebuild the database to allow continued streaming of music, videos and pictures. Depending on the quantity of media files stored to your device, the database rebuilding process may take several hours to several days to complete. During this time, you will not have the full functionality of the media server available.  You may not be able to stream all your media content or see all your thumbnails display.  After the rebuild is complete, you will be able to access and play your media files through your media player.

1 Like

Any chance of a link to the previous firmware version, in case I want to revert? I’ve tried "" but thats not it…

Or, will a safepoint save all the firmware as well as the data?

Unfortunately, once you update the firmware on My Book Live Duo you cannot roll it back to a previous version.

Pretty sure you can just edit /etc/version and /etc/version.* with info about 02.30.19-277, then load 02.31.08-067, which I found, thanks, it was from May 15, not 16. Anyway, will definitely wait till others have “beta tested” the newest firmware before risking it on a system that has twonky working perfectly on it.

You have Twonky on your Duo? I have heard of people putting T 7.1 on the Live, is it the same for the Duo?

If so, have you ever updated and had it maintain Twonky?

Asking because I have thought about doing it, but have not. If you can still update after making the switch then that is one more reason to…

I just updated to this build by downloading it and doing a manual update. So far it looks like the updated MBL interface, with the hidden shares shown and the link to Public on the dashboard.

I just restarted my MBLD with the latest firmware. Some random feedback:

 - I tried doing a backup immediately after upgrading. It took a long time to find the backup disk, but once it did, it’s been backing up 10x as fast as before. I’m already 3GB into a 14GB backup that I started recently and last night I wasn’t able to complete a 11GB backup at all.

 - The quota limits for Time Machine are nice

 - I haven’t got the Java plugin to view files working on my Mac at all (none of the browsers make this convenient at all - maybe it should be a WebStart thing instead).


Looking good so far. My 14GB backup is nearly none by the time I got around to finishing this message.


Since the upgrade I can’t login to the drive - error message appears saying a problem with the webpage causes the page to crash - any help appreciated (I am not a seasoned IT person!) 

Sounds like the Java issue mentioned earlier. Either try a different web browser, or make sure you have the latest version of your current browser, update java, java plugin, etc.

1 Like

I can’t find any release notes for the firmware update! Anyone knows where to find the release notes telling what’s new in this version??!

Look here:

I have installed the new firmware version.

I just get an error message at the end of installation, but it seems to work.

It seems to have solved my compatibility problem with my Livebox router.

I can access to my data and picture from my mobile.

I didn’t do test from my TV by watching video. I will try this afternoon.

[EDIT] I did the test, it works perfectly

Mamini wrote:

I can’t find any release notes for the firmware update! Anyone knows where to find the release notes telling what’s new in this version??!

Good morning,

I upgraded my firmware on my MBLD yesterday afternoon.

At the end of the upgrade I also got an error message saying that the firmware upgrade failed. I click on continue or retry and finally got a message saying that my MBLD has been sucessfully upgraded to the latest firmware.

My DLNA server does not seem to be crashing anymore… However, yesterday I was watching a few 30 minutes tv show in .mkv that are hosted on my MBLD. Every show I watched, the image/sound frooze a few time (sluttering) during the show. This was NOT happening before.

Is this due to the DLNA rebuilding the database ?

How to know if the rebuild of the database is done ?

I will try it again tonight but i’m very sad to see that another issue has appeared… Hopefully it’s only a temporary issue…

Anyone ??

I upgraded mine and the experience so far is good.

The DLNA server is MUCH more responsive and reliable.

It’s working will with:

   All of my WDTVs (Live, Live +, Live Hub, Live SMP)

   My LG 55X6500 TV

   My LG 3D Bluray Player (can’t remember the model)

It took about 20 minutes to full “catalog” my media, and spent at least 24 hours generating thumbnails.

SpykeYs wrote:


How to know if the rebuild of the database is done ?

Yeah, the “Status” of the dashboard isn’t really useful.  It doesn’t give any indication of what’s going on in the background.

What I did was log in via SSH and watch the “top” command.

Looks like this:

top - 07:58:26 up 0 days, 14:48, 1 user, load average: 1.46, 2.12, 1.83
Tasks: 101 total, 1 running, 100 sleeping, 0 stopped, 0 zombie
Cpu(s): 0.3%us, 0.3%sy, 0.0%ni, 99.3%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 253632k total, 242368k used, 11264k free, 23040k buffers
Swap: 500544k total, 108992k used, 391552k free, 76608k cached

26230 root 20 0 5056 3456 2368 R 0.7 1.4 0:00.08 top
    1 root 20 0 4352 1664 1344 S 0.0 0.7 0:01.54 init
    2 root 20 0 0 0 0 S 0.0 0.0 0:00.00 kthreadd
    3 root 20 0 0 0 0 S 0.0 0.0 0:00.94 ksoftirqd/0
    4 root RT 0 0 0 0 S 0.0 0.0 0:00.00 watchdog/0
    5 root 20 0 0 0 0 S 0.0 0.0 0:00.10 events/0
    6 root 20 0 0 0 0 S 0.0 0.0 0:00.00 khelper

When the server is still doing “stuff,” the CPU will be *VERY* high.  Above shows it to be < 1% 

If it’s still doing “stuff,” the top entries will be things like:





and the CPU will be > 70% busy, like this:

top - 08:03:29 up 0 days, 14:53, 1 user, load average: 2.49, 1.86, 1.76
Tasks: 101 total, 1 running, 100 sleeping, 0 stopped, 0 zombie
Cpu(s): 94.3%us, 3.9%sy, 0.3%ni, 0.0%id, 1.2%wa, 0.0%hi, 0.3%si, 0.0%st
Mem: 253632k total, 245824k used, 7808k free, 16320k buffers
Swap: 500544k total, 110848k used, 389696k free, 88640k cached

17312 root 4 -16 52736 10m 4480 S 99.9 4.1 1452:01 dms_smm
 5059 root 30 10 20416 9088 2624 S 0.6 3.6 425:56.13 mediacrawler
26718 root 20 0 5056 3392 2368 R 0.3 1.3 0:00.11 top
    1 root 20 0 4352 1664 1344 S 0.0 0.7 0:01.55 init

Overall, yes, there are still some issues, but at least the DLNA server is USABLE now.   Previously, it was so bad as to be worthless.


I’ll have to try again when I get back home later today…

Hopefully the MBLD was doing something and that’s the reason I was getting some sluttering…

Will keep you updated on that…

Since updating to latest firmware, have lost access to Dashboard

When you try to open the dashboard is there an error message?

Is the LED on the device currently green?

During the update did  you notice the LED stay on a white/violet color LED?  If you saw this then it means the update was progressing.

Did you try powering off wait a few minutes and then power on the unit again?

This has also happened to me, but it did not last long. If you JUST upgraded, then give it some time.

Am glad to see the new firmware, however I still seem to be having some issues with Samsung products.  My TV and Bluray both are having problems with some of my media files.  Yet those same files stream from a ASUS router with no problem.  I was also able to stream those files from the MBLD to a couple of different Android devices(none samsung products) with no problems.  Just seems to be MBLD to Samsung for me at least.

Just wondering if anybody else has had anythin similar.

Yes error message is: a malfunctioning or malicious add on has caused internet explorer to close


LED is currently green

Cannot give any information on white/violet My book live is in another room.

Yes powered down removed mains and ethernet cable replaced them and unit powers up but still problem persists.

I upgraded about 10 hours ago

Rather concerned the unit is about 2 weeks old and had not started to back up any files.

PC is running XP

Thanks for your interest