New Release - My Book Live Duo Firmware Version 2.41.05-034 (2/28/13)

WD is happy to announce the release of its firmware update for the My Book Live Duo. Feel free to post your experiences in this thread.


Update done without any problem.

Unfortunately my WD my book duo live is about 6 hours hanging on 4%. Any ideas how to fix this?

Initial FW update failed, was reported by nas.alert.

Instruction was to retry. Retry initiated, now watching it stalled at 100% downloaded, still warning not to unplug.

Think I’ll go to the store. Maybe it will have failed by the time I return so I can contact Customer Care as I WILL be instructed.


Unbelievable.  That’s all I can say.

I’ve just checked the last thread on the “newly released firmware” that was posted late last year.  I’ve held out updating to that one because of all the problems people were having.  Nonetheless, I keep checking to see if there’s any news on a fix.  But instead I find that thread closed a few hours ago because there’s “new firmare”.

So I happen over here and lo and behold, people are having problems with this, the latest and greatest installment of alpha-ware, courtesy of a comany who couldn;t give a rat’s.


Like everyone else, I’m in this for AUD/US$300+ and the risk of losing data.  And here we are, all of us playing the test dummy team for WD who cannot BOTHER to test any software they release.

I could have bought a couple of 2Tb disks and have everything simply backup to it using the OS built-in software and saved half my money.

What a bloody DISGRACE.


The download and installation took about 15 minutes. The subsequent rebooting took as much time again, maybe a little longer, 20 minutes (say).

My first task within 1 hour of the upgrade was to attempt a drag&drop copy of my email archive (16+GB) to a network share on my MBLD using wireless. This task normally takes between 100 - 120 minutes under the previous firmware. Following the latest upgrade the very same task takes less than 30 minutes. It looks as though wireless operation may have been greatly improved. The same task with cable takes about 6 - 7 minutes. I doubt the cabled performance could be improved still further.

It maybe that the firmware upgrade has speeded up the process of transferring data between MacBook Pro and NAS. I am presently trying to determine if TM backups are any faster. I have performance stats under the previous firmware so it will be interesting to see if TM backups, wireless & cabled, are any faster.

I DID buy two 2tb 7200rpm Seagate Barracudas. Installed in my Mac Pro as RAID. Works as expected - super fast.

But, I also wanted to save my WD investment. The new firmware version installed in a little under an hour, is still rebooting last time I looked - over half an hour so far. I have about 0.7TB on it and it looks like it may be rebuilding directories - flashing green light. I’ll be interested to see if I get read/write times I can live with now. I’ll report back. Cheers.


I have 3Tb WDLivebook storage since October 2012. Initially it was filled of 2Tb of media files and worked without any problems and warnings.

Since succesfully updating this firmware my greenlight on front side works permanently even out of connection from LAN!!!

I received 2 warnings about high temperature which never happend before!

What is going on inside my Livebook?

BW, Teymur, Russia

Howdy I can get the upgrade to download, but gets to the installing part, 10%… hangs for a while then I get the 31105 Upgrade Copy Failure message.

Have tried numerous times with the same error.

Please help!!!

Updated to new firmware with no issues. 10 minutes all done. I have the iTunes server turned off.

Update went through without a single hitch.  :smiley:

The bug setting trustee permissions to USB connected devices is still there…


Seems firmware update destroyed my device and half of the content that was on it (I had backed up most of it but not all over the past few weeks).

Lots of the data is irreplaceable like pictures and the like. Trust me, if your drive is working fine before the update, then don’t update… or run the risk of my unit.

RMA here I come.  So disappointed with WD as a whole.

Greeced, did you make any exotic changes to the Linux operating system on the MBLD?

How many power-cuts has the MBLD had?

Exotic changes?  No idea what that means… I have done no changes to it whatsoever.  I wouldn’t even know where to begin.

As for power cuts?  There hasn’t been any power outages here, and the only time I powered it down was when I was suggested to roughly 10 hours after the firmware update said it was successful.

The drive is done.  I have no dashboard now, no SSH now (had it before when I tried to update from file, but that didn’t work at all).

Drive was working fine yesterday morning.

  1. Logged into MBLD, the unit said there was a firmware update.

  2. So I continued with it.

  3. It downloaded and went through the process.  

  4. Said it was successful and it was rebooting.

  5. After rebooting, just said “initializing”  for over 10 hours non-stop.

  6. During this time, the dashboard went from 312GB / 2TB (RAID 1 Setup), to 0MB / 0MB.  

  7. Subsequent logging in to the dashboard I would either see 0GB / 0TB… moments later 0MB / 0MB.

  8. Throughout all this, my drive light was a solid yellow.

  9. So I downloaded the file from the website again and extracted the .deb file and went to update from file thru the UI.

  10. Because the UI stated 0MB / 0MB, it said there wasn’t enough space on the drive… I think it was error 31505.

  11. Several reboots got the thing to 3GB / 4TB on its own (at this point I knew my data was screwed).

  12. After a few seconds 0MB / 0MB

  13. I went into the Shares area.  Sure enough, Public was there, but displayed 312GB / 0TB. but I couldn’t access it.

  14. After a couple of more reboots via the UI, the shares showed 0/0

  15. I was pissed that I lost my files, but at this point I tried a factory reset through the UI.  Didn’t work.  Rebooted sure, but light stayed yellow and “Initializing”.

  16. So I left it running from 4pm til 8am the next morning… Woke up and guess what… Still initializing.

  17. I read on the internet that I could update via ssh, so I proceeded to do so… but same problem as before.

  18. Now after a couple of more reboots via the UI, the UI didn’t want to show up anymore and I noticed via the smartware that I could access the Public folder, but the contents are not there at all, only the default folders.

So did I do anything exotic?  Not sure what that means… If your trying to find fault in the user here, look elsewhere…This was a fault of WD.  Either there firmware or the drive.

So unless you have a miraculous fix for it, I’ve already submitted an RMA.

I only want this thing for storage of important files.  I wouldn’t go screwing around with it to “get more horsepower” or something.  I couldn’t care less about that.  No matter how slow it is.

My “exotic”, some people install extra stuff through SSH. Obviously you’ve used it as it was supposed to be used.

Sorry that it’s gone gaga on you.

I admit I’ve been sceptical on performing upgrades, but so far I’ve initiated two firmware updates using WD’s QuickView app.  Previous updates I started from the Linux shell after downloading the upgrade file and copying it to the MBLD (or MBL) before directly invoking the the upgrade script.

I know. Not an ideal way to do an upgrade.

What I also usually do is turn off all the services on the NAS and then reboot it. Immaterially after a reboot I perform an upgrade.

When the replacement arrives, first thing to do is enable SSL.  Reason for this is that it not only alows Telnet access but also enabled SFTP.  If it goes gaga then you should still be able to use FileZilla to sign onto the NAS as the Linux root user and retrieve your files.

I would walk you through recovering your data and debricking the drive but your reply to Myron suggests you are not the kind of person who likes to tinker.

Actually, it’s not that I don’t like to tinker, I just don’t find the need when the unit is under warranty.

Having said that. In a desperate attempt to get my files back, I did try your debricking method (after my RMA call) and it only worked somewhat

  1. It seems to have rebuilt the unit, but my files are gone.
  2. I can only access the drive through quick view.
  3. Ssh not working
  4. Dashboard still not working.
  5. Light on unit is now Red.

Did you try using R-Linux or DiskInternals Linux reader to see if you could pull the data off disk A or B?

My guess is your partitions got corrupted somehow as the script turns on SSH access after it copies over a factory fresh OS image. You could try again using GUIDE 2, but I would try to recover your files with the above mentioned programs if possible first as GUIDE 2 recreates all partitions and formats the drive.

On a MyBookLive I believe the RED LED is indicative of the data volume not mounting as I have installed the MBL DUO firmware on a MBL and ran into this issue. Without SSH access there is nothing you can do to fix this. On my MBL all I had to do was add /dev/sda4 to mtab and then mount /dev/sda4.

Ya, unfortunately, the files are gone.

As for SSH, the script didn’t seem to turn on ssh… I still don’t have access to either the UI or UI/ssh.

Question, if I do try the destroy method in Guide 2, do I have to do it to both drives or just drive A?

Personally, I don’t really care at this point as I’m getting a new drive from RMA (they advised me to try some programs for recovery as well)…so this might be a learning experience for future when the drive doesn’t have warranty anymore.

I tried your method only on Drive A.

I wish I could answer that question, but I can’t. I would try with drive A 1st and do the quick factory restore and see what happens. If still no go you may need to run the script on disk B as well.