New Release - Firmware Version 2.3.01 for the WD Sharespace (9/12/11)

Please post your experiences to this thread for the new update.

Please HELP!!

I’m having the same problem here after upgrading to the latest firmware. I cant connect to the GUI, cant connect via AFP or SMB. Im totaly lost here…

The upgrade went fine, but after the system rebooted i lost all connections.

Does anyone have any idea what’s going on? It seems that a lot of people are facing this issue.

WD!! Help US!!!

If you don’t care about data, then open the case as per manual, make HDD numbers and change order of HDDs. It should make full system restore from ROM and reformat all HDDs. Don’t cut the power for 35-40 hours while all four HDD LEDs blink in green.

AKazak wrote:

If you don’t care about data, then open the case as per manual, make HDD numbers and change order of HDDs. It should make full system restore from ROM and reformat all HDDs. Don’t cut the power for 35-40 hours while all four HDD LEDs blink in green.

That wouldn’t be the first thing i’d try…

Have you tried a full power-down (let sit for 10 min), and restart? Have you tried to access from another computer on your network?

After updating the firmware on my Sharespace (wich went fine), I can’t connect to it via Time Machine.

"There was a problem connecting to the server “WDSharespace.local”

Same error.

Seems like http service is not running.

I can connect to twonky on port 9000.

port scan identifies 21, 849,1025,2049,9000 and 61225.


I do care about my data… I bought this NAS thinking about protection against hardware failure… but software failure??? comon… this is ridiculous… The firmware upgrade went smooth with no errors… how come something like this happens???

For serious… i think apple should rule this bussiness… just tell me who in this world have time to worry about this issues??

Before the firmware I was facing random power shutdown, connection instability, my router´s log was flooded with wierd messages coming from SS… serious… I really appreciate everyone´s help but didn´t WD tested the firmware before??

The" best thing" is that I spent a lot of money buying this NAS ( i´m not in USA) and I can´t see how to trust my data anymore on SS… IF someday it´ll be running again… This is pissing me off… sorry about this bla bla bla.

Upgraded and now the system won’t come back online. It reboots, 4 blinking lights, then the power light goes off.

Any suggestions?

 help me please !

I cant connect to the GUI, as admin user.
I can use data as user , but i cant manage the system !

The upgrade went fine.

Does anyone have any idea what’s going on?

It sound like the http server is not running. The quickest way to try and fix it is to do another reboot in hopes it will auto-start. Barring that, if you are comfortable in the Linux world, login to the sharespace via ssh and try to start it by hand. The startup file is in /etc/init.d. do “/etc/init.d/S55mini_httpd start”.

This assumes the upgrde did, in fact, go to 100% to completion, otherwise not so good for you.

If you can’t login via ssh, then the sshd daemon isn’t running and you can only try another reboot.


I have the same problem, when I go to the web interface I just get a blank screen.

mini_httpd is running, I even did a restart, checked the permissions on the all the files, the mini_httpd log doesn’t have anything useful, just that it can’t find favicon.ico

I did a netstat and saw that it was listening on port 80 & 445, and as a previous poster mentioned, I can get to the twonky server via port 9000

Any other ideas?

Wait for the fix to the fix.

try different browsers or delete the browser cache.


I did.

I was using Firefox at first, then tried in Safari, no go.

At least I can connect to it from Lion now without using having to resort to NFS

Im a mac/ pc/ linux/ android user and i cant reach SS anyway… Im sure that we all tried to reboot, use another computer, pray, sleep hoping that everything will be ok next day before we post our threats here… As i said before… I do appreciate everyone’s help but we ( me at least) are clueless about this issue… My SS is unreachable… But i still receive message from the deads… Lol (i still receive emails from SS status… Lol)… Anyway… We must have serious help here… We dont even have a starting point… Tks

I can no longer access the WDSharespace from my 10.5.8 Mac Mini and 10.6.8 MacBook Pro via AFP. The follow error occurs: Connection failed. The server may not exist at the time. Check the server name or IP address and your network connection and try again. The Finder cannot complete the operation because some data in afp://WDSharespace could not be read or written (Error code -36)

However, I can connect via SMB://WDSharespace on 10.5.8 and 10.6.8.

How the **bleep** can WD release a firmware update and still break things? Doesn’t WD QC these things? Is this WD way, “let have the consumer users field test official relase firmware?”

Absolutely, terrible. 1st you release a NAS with 1Gb ethernet that runs at 10Mb/sec. Now you release a firmware that breaks connectivity. Bravo!

1 Like

Still having connectivity issues - can’t connect via the smb share or via the gui. device boots up, 4 blinking greens and a green power light. power light goes off after about 10 secs and 4 greens remain solid. network connection light is green.

As far as I can tell this firmware bricked the device… anyone have ANY suggestions on how I can gain access, at all? I contacted WD Support but they haven’t responded.

@fatboy. This message is most likely caused by the AFP daemon not running (happened to me). Try rebooting or, sigh… you can login to the sharespace via ssh if the ssh daemon is working.  invoke the command; “/etc/init.d/S91atalk start”

do a “ps -ef | grep -i afp” to see if the afpd is running. It will look similar to this if it is:

1162 root       1520 S < /usr/sbin/afpd -g nobody -c 50 -n Rhododendron


Hello again… I’ve been looking around in the forum and I realized that this is not the first time users bricked their SS after a firmware update… What they did to solve this issue? The worst part is that I cant ssh my SS… its compleatly blocked… Is there a way to force a full factory restore?? I dont care about the data anymore… I just dont want to toss my nas away… Thanks again.

Hi All

I have updated SS to latest microcode, but I always get reset to factory defaults after each power cycle or reboot SS.

How can I fix it?
How can I downgrade firmware?

Best regards,