New firmware 2.3.02

At least WD hasn’t completly given up on this thing… Just a small bugfix but at least it gives us hope that they’re still working on it.



Still alive and kicking :smiley:

Are they ever going to fix the transfer rate or do I just throw them in the bin.

Really, whats the point of having over 5gb storage when it takes weeks to transfer.

They keep talking gigabit network, what a joke…

Could you share your experience of upgrading (automatic or manual) to  version 2.3.02 please?

I performed today an upgrade to Firmware Version 2.3.02 for my WD Sharespace 4To.
After upgrading, the system won’t come back online. It reboots, 4 blinking green lights, then the power light goes off after 20 seconds. I tried to reset my WD Sharespace with resetbotton on back but this functionality didn’t work. After consulting the discussions, samilar issue occured with former version 2.3.01.

Any tip or fix will be welcome!!!

Did the upgrade, upon complete, the drive rebooted itself and login window appeared. Then wrote admin/admin and said that user and password doesnt match.


Did the 20 sec reset several times, but says the same cr@p.

Theres no email support and tried the telephone support, but the answering machine says that I should go to to get support… 

Havent found any help in the FAQ… 

If you found the answer please post it. I just did the firmware install. I can get to the login page but can’t get past. Tried using the reset button for 20 seconds and watched the lights change but still can’t login with admin/admin.