New Release - Firmware Version 1.04.17_B for WD TV Live Plus (12/30/10)


#1

WD is happy to announce our latest firmware update for the WD TV Live Plus Media Player.  

Known Issue: Fast navigation in Deezer can sometimes cause a device reboot.


#2

The internet update took me from 1.03.29 to 1.03.49, then offered up 1.04.10 which wouldn’t even start updating. I downloaded 1.04.17_B to a flash drive and I’m installing it now, but it seems to be looping the “updating firmware” again and again (3X now and still going). How do I stop it ?

HELP


#3

You probably tried before the update server was fully configured… That has happened to me.


#4

I installed 1.04.17_B using a flash drive and it keeps looping (installing, rebooting, etc) over and over. How do I stop it ?


#5

Uh oh. That ain’t good.


#6

After about 6 loops, I decided to pull the power plug and remove the flash drive (during a reboot). After 10 seconds I plugged power back in and it stuck at the WD logo. I used a paperclip and nothing happened. I unplugged power again and this time a weird screen appeared asking me to insert a USB Drive with firmware to recover the WD Media Player. I plugged in the flash drive again and I’ll see if it still loops.

It’s still looping.

I rolled back to 1.03.29 and it’s still looping. What the heck do I do now ?


#7

Go see KB article 5800 in the support section at www.wdc.com


#8

That’s just the rollback instructions. I have rolled back before and know what I’m doing. I’ve never had this looping problem though. It’s still rebooting and appying the firware update (new or old) over and over.


#9

Your post, before you edited it, asked where the older firmwares were. That’s where they are. If that doesnt fix it, call WD.


#10

MKVs still broken…


#11

Goats wrote:
MKVs still broken…

Thats kinda vague… My MKVs are playing just fine… Watching Avatar right now, actually…


#12

Scratch that MKVs and AVIs broken. Choppy and no sound. Returning tomorrow.


#13

Tonyph your Sig does not say you have the live plus. Which I believe is what B is for. I have 4 in my home and work for a retailer that sells these. We tested in store and live plus is not playing any videos right.


#14

I downloaded the new firmware to a usb stick and I’m stuck in an upgrade loop as well.


#15

I just updated the firmware and I now I no longer get a signal through HDMI, what gives? Is there a way to roll back to the previous firmware which worked fine? This is ridiculous that a firmware update would create more problems!


#16

Yes, my sig does say I have a live+…, and I’ve tested 15 different file combinations on both (actually all three) and every file plays flawlessly… I have no idea what’s wrong with yours. And the fact that you work for a retailer that sells them is non sequitur .


#17

I did not test AVI though, I don’t have any and never will… It’s a dead standard.


#18

I spent over an hour trying to fix the firmware upgrade loop and gave up. I unplugged everything and will call WD tomorrow morning. (hope they’re open)

In the meantime I connected my new standby unit (Patriot Box Office HD) that I got for almost nothing from Amazon.com last week. The navigation is clunky compared to the WD but everything works !


#19

I give up too… I think its funny that i’m trying to watch my MacGyver dvds and i have to “MacGyver” this stupid thing to work right… If only i wasnt too lazy to go downstairs to get some duct tape, my swiss army knife and a pair of hockey tickets…maybe i could whip up a popcorn device.


#20

Ok… I lied,i didnt stop. Using my “magic stick” from mt last rollback, i got the device back to 1.03.29. I then did an automatic update instead of using my usb. I took me to 1.03.49 It then prompted me to update to 1.04.10…i did so… Reboot It then prompted me to update to 1.04.17…i did so Reboot Since im only watching 90’s tv shows i dont mind playing guinee Pig, but i can see why people are getting upset. Its not in the release notes, but im hoping they in some way shape or form addressed the streaming vobs issue. Im not in the mood to convert to isos…if not…ill just strum along merrily on a rollback to 1.03.29… If it lets me roll back…

edit…sorry for my formatting…im typing this on an ipad and it only lets me use html…and i refuse to rerach back into my mind to remeber html code…it is almost 2011 afterall…its also a pain to select the brackets on an ipad to open and close tags…stupid ipad. :slight_smile:

edit again…vobs still drop out. .no biggie…the realase notes didnt indicate It was fixed, so i cant hold them to it