New MyCloud EX2 Ultra - stuck during boot up, endless blue flashing

Short version: WD MyCloud EX2 Ultra seemingly stuck during boot process (status LED flashing blue over hours, no network connection possible). What can I do?

Long version:
the nice offer on Prime Day made me buy a WD MyCloud EX2 Ultra.
I finished the first setup without problems, got familiar with its usage pretty fast. A firmware update was available and I installed it yesterday. The NAS rebooted after that and worked without problems. Over night I started to copy the contents of my external USB drives to the NAS, plugging in my USB hub to the NAS. All drives were detected properly. Since copying is files directly is a lot faster than using my notebook for this, I enabled SSH access and copied about 500 large files over night via “cp”, each about 1-4 GB.
Worked like a charm, copy process was finished this morning.
Today afternoon after work, when accessing the NAS via web interface, I noticed it responding kinda slow. Accessing the USB drives was nearly impossible, so I decided to make a soft reboot via web interface.
Now the problem: the reboot process never ended. Status LED is flashing blue, this went over an hour. I plugged out and in the power plug, same scenario. Flashing blue for over an our. Then I tried the “40 seconds reset” - didn’t change a thing. Flashing for 3 hours now, I don’t know what to try next.
Does anyone of you have ideas?
I definately didn’t brick anything during SSH access, only used “ls”, “cd” and “cp” commands in the /Shares folder.
Thanks in advance for your hints!

The problems solution: sent it back to Amazon and got it replaced, and didn’t do any firmware update, like the last time. I only want to use it locally for data, the cloud features are useless in Germany, anyway (upload speed too low).