New my cloud not backing up to time machine

I’ve got a new my cloud - This is a replacement for an old one that that is not compatible with OS5

I’m struggling to get it to back up to the time machine for the first time

It connects, prepares to back up then nothing completes with no back up completed

Any ideas where I go from here?


Have you looked at the User Manual for the My Cloud Home?

User Manual: My Cloud Home and My Cloud Home Duo (

Search Support | Western Digital

My Cloud Home Time Machine Backups

In [Time Machine on My Cloud Home not working anymore] we are talking about it.
Best regards.

This is the sub-forum for the My Cloud Home, not the My Cloud.


I sent mine back last week, same situation as you, purchased a new one to replace old one that support was ending on… nobody could fix the time machine issue for me so I sent it back - Im still waiting for my refund though!!

Wow - This is terrible

I tried all of their troubleshooting tips etc , technical support via email but nothing worked so sent it back for a refund - seems to be a massive issue… what OS are you using?.. Im on Monterey - think they need to stop selling them until this issue is fixed - Im proper gated though as i had my old mycloud for many years with no issues at all - purchase a mycloud home via the replacement scheme and boom there goes my way of doing TM backups… not sure where to go in terms of devices for TM now as Ideally I want something similar to cloud so i don’t have to continuously have my devices all plugged in.

:disappointed_relieved: :tired_face:

Monterey - This device has been miss sold to me - Terrible

Current one has become redundant as OS3 is being pulled , buy a new one and its not as good as the old one…

Poor form this