New FW: 2.21.111 (13.7.2016) - share your experience!

There is a new firmware 2.21.111 available. Anyone tried it yet? Lots of issues resolved…

I havent tried it yet, need to backup DL2100 at first before installing new fw.

Seems to work fine. No problem with installation (via dl2100) and nothing changed.

I installed last night in a EX4100 and nothing changed. Does anyone find any documentation about this update?

I have just found Software and Firmware Downloads | WD Support

So far it all installed without a hitch. :slight_smile:

Myron, it seems one of the fixes was for your sudden power loss problem, right?

I just recently put the last update on, and I have none of the issues listed, so I will give it a go in a week or two.

I also upgraded and have experienced no new problems so far.

After the update my USB backups didn’t work anymore.
I had a WD MyBook 6 TB attached to the DL2100.
Backup Failed !
I have to delete all backups and make new tasks.
After this all back to normal.

I lost WAN access to MyCloud and WD Sync after the firmware update on my DL4100. LAN access seems to be fine and this includes logging into MyCloud on any machine within my LAN. I do still have access my control panel on the WAN. Anyone else have an issue like this before?


I also had three backup jobs I had created prior to the update which backup select Public folders to an external WD My Passport Ultra 2 TB USB hard drive. My jobs were still there after I upgraded the firmware and when I ran them again, they worked as before.

Note: I have to manually initiate my backups, I do not have them do the “automatically update upon connection” thing.

Slight problem I had, accessing EX4100 via 4g phone, was that I had the EX4100 take a bit of time to wake up from sleep mode, and my phone connection was revoked several times.
| had to re-register the phone with the EX4100 each time after
Remedy was to choose connection mainstay for longer than original 1 minute, and I chose 9 minutes maxed.

With this upgrade, the EX4100 is taking a lot more time to wake up from sleep mode, than the previous firmware. Did not revoke my connection yet via the mobile, but it has only been 24hrs since the upgrade.