New firmware stopped my linux mount of live hub


#1

Hello

I recently update the firmware on my live hub to 3.11.10 and now I can no longer mount the device remotely to a linux comnputer.  This is what I am using to mount

mount -t cifs -o username=guest,password= //192.168.1.126/WDTVLiveHub /mnt/live

I have verified the ip address, I can ping the device.  I have also tried to mount //192.168.1.126//wdtvlivehub

neither work.  I have used no password and even set a password for the device and tried that.  neither works.  Seriously just when I started thinking this box was cool it breaks a second time when I install new firmware.


#2

and what does smbclient show you


#3

Net skink, what error does it return?

By the way, you’re in the wrong forum.


#4

[root@x200 ~]# smbclient -L 192.168.1.126 -U%
params.c:OpenConfFile() - Unable to open configuration file “/etc/samba/smb.conf”:
No such file or directory
smbclient: Can’t load /etc/samba/smb.conf - run testparm to debug it
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.5.6]

Sharename Type Comment


WDTVLiveHub Disk WDTVLiveHub
IPC$ IPC IPC Service (WDTV LIVE)
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.5.6]

Server Comment


DAVIS-PC
FRANKLIN-PC
WDTVLIVEHUB WDTV LIVE

Workgroup Master


SKINK SKINK
WORKGROUP WDTVLIVEHUB
[root@x200 ~]#


#5

It’s still working fine for me:

[root@mars mounts]# mount -t cifs -o username=guest,password= //10.0.0.123/WDTVLiveHub /mounts/temp
[root@mars mounts]# ls temp
3D test
50 First Dates.iso TwonkyMediaServer-log.txt
50 First Dates.metathumb WDTVLiveHubLR_2011.11.02_17.27.44.jpg
50 First Dates.xml

#6

are you using the latest firmware? Using your exact command, I get permission denied.

I’ve enabled linux shares  and reset the device to factory defaults after installing the firmware and then renabled linux shares.


#7

netskink wrote:

are you using the latest firmware?

Yep…   I have TWO Hubs on my network, both running the latest FW.  Here’s the other one:

[root@mars mounts]# mount -t cifs -o username=guest,password= //10.0.0.126/WDTVLiveHub /mounts/temp
[root@mars mounts]# ls temp
bby_complete_list.xml
bby_waiting_list.xml
home.php
Prometheus (Premium).wmv
Screenshots.zip
Seeking a Friend for The End of the World (Premium).wmv
SHOT 1.jpg
SHOT 2.jpg
The Cabin In The Woods (Premium).wmv
The Dark Knight Rises (Premium).metathumb
The Dark Knight Rises (Premium).wmv
The Dark Knight Rises (Premium).xml
TwonkyMediaServer-log.txt
WDTVLiveHub_2012.09.18_15.48.39.jpg
WDTVLiveHub_2012.09.20_14.18.29.jpg
WDTVLiveHub_2012.09.20_15.22.40.jpg
WDTVLiveHub_2012.09.20_15.29.29.jpg
WDTVLiveHub_2012.09.27_16.56.42.jpg
WDTVLiveHub_2012.09.27_16.56.50.jpg
WDTVLiveHub_2012.10.05_03.49.46.jpg
[snip]

netskink wrote: Using your exact command, I get permission denied

Did you, by chance, accidentally turn on Device Security in the Hub Setup options?

netskink wrote:

I’ve enabled linux shares  and reset the device to factory defaults after installing the firmware and then renabled linux shares.

Enabling linux shares is meaningless.  That option allows the Hub to connect to NFS shares.  It has nothing to do with a linux client accessing the Hub via CIFS, which is what you’re doing.


#8

Well i managed to get it but its sad.

Under network share managment on the wdtv live hub, you need to disable windows share server and then renenable and select a login/password pair.  Then use the previous mount commands using that username and password.

I also tried to renable sharing with no username/password and then tried to use guest login with cifs mount and no password, but that fails.


#9

netskink wrote:

Under network share managment on the wdtv live hub, you need to disable windows share server and then renenable and select a login/password pair. 

Huh?  I’ve never once done that.