New Firmware Release - Version 1.01.10 for WD Elements Play (10/27/10)

Mine shipped with the new one.   That’s why I ask.

1 Like

I guess that’s the best was to get it on then…

have it pre-installed.


I tried again last night with a brand new sandisk 16gb USB key.

  • after the WDEP booted I inserted the sandisk

  • system noticed that a new firmware version was present

  • tried to perform the upgrade.

  • crapped out after about 10 seconds - with the same error as always

It’s like I either can’t write to the EPROM or it’s locked out in some way or there’s not enough space to accept the new firmware. The only consistent ‘element’ (no pun intended) is the failure after about 10 seconds.

WD Moderator;  Is this a possibility?

Hi ecciethetechie,

Hi ecciethetechie,

did you get it to run? I mean the firmware (Install)?

I also tried everything, but i think there is a problem with the WD Elements Player!

It seems lots of people have problems with the new firmware.

I got my player last Saturday and after loading some music on it i decided to install the last firmware.

Just downloaded it, put it on a empty USB stick and extracted it.

The player was already on so i just put the stick in and he found the new firmware and after

confirming he started installing and now i have the nice new firmware :smiley:


Just a question for whom has problem with the firmware update (like me): have you partitioned the hard disk?

I divided the HD in two parts and I suspect that it could be the reason for the problem with the update of the firmware.

Hi, no, I didn’t partitioned the HD. Everthing is in standard configuration. After I put the USB Stick in the player, it found the new firmware, but after 10 sec. it brings a failure and the Player restarts again to the homescreen. Don’t know what to do further more :wink:

Thanks for your response. So, the HD partition is not the cause…and the problem remains…

I’m a little disappointed for the silence of  WD. It’s clear that, in addition to the problem of the player, there is also the problem of the software update, released to solve the problems…

Have either of you contacted technical support?

Of course. I contacted the wd support for Italy and they didn’t now about this problem. I told them that in the wd community there were many people with the same problem. They told me that my problem is investigated by the second level of the technical support, but  I’m still waiting to be contacted back…

How long has it been?   If more than a week or two, I’d push them to RMA your unit.

Yes - I still have the problem.
No - I didn’t partition my drive (Full 2TB [or whatever the partitioned equivalent in bytes is] on one partition)

RMA’s? - They’re going to have to issue a lot of those. If we are all having the same problem then you can bet that there are others (Including those who don’t generally look for firmware upgrades) who have this issue.

WD give us a new version of the firmware… We want the issues sorted.

Issues I currently have:

  • Playing MP4 files – little skips every 30 seconds or so - looks like it’s re-syncing the audio - very annoying.

  • Playing MP4 HD – converted using Handbrake – FORGET IT - stop go motion - unwatchable.

  • mkv SD – lip sync issues

I have a Netgear EVA9150 and a lot of movies in mp4. I don’t want to recode anything.

<<<<<< WD GIVE US NEW WORKING FIRMWARE >>>>> :frowning:

Well, a new firmware isn’t going to fix anything if your EP won’t load it, so an RMA may still be required.

With all respect to you Tony.

How many RMA’s do you think WD will need to issue here.

If I was the only one with the problem I’d agree, in spite of WD’s Advanced Replacement option, it is still a hassle for those of us who have purchased the 2TB drive (which seems to be the ones having the problem). There are a lot of hours required to transfer our content, especially via USB to USB.

You are also assuming that the fault lies in the device and not in the software. I hope you’re wrong, because, if you’re not. WD need to perform a product recall.

Do you really think the engineers and QA testers at WD allowed this product to escape their facility. They should have their ISO certification revoked if they did (I am assuming they follow industry wide standards and practices).

If WD say they can compete and produce a media box equal to the competition out there, then that’s exactly what they should do… 

My WD elements is 1 TB and I have the problem of the firmware update, so it isn’t only for 2 TB…

Well, considering only two people have reported your problem, I’m pretty sure only three possibilities remain

1>  Your unit is malfunctioning.

2>  You’re not doing it right.

3>  Your upgrade media is bad.

Who knows how many THOUSANDS of units upgraded correctly?   In fact, the majority of the users posting in this thread said it works fine.

If the new firmware is flawed, then EVERYONE (or at the very least, more than two) would have the same issue.  

OK there me and Obleix with this problem

Anyone else?

let’s hear ya!

The numebr of views of this discussion suggests that more thna 2 people have this problem…

Anyway I’m in contact with the WD support and, if necessary, we will arrange for an RMA.

obleix wrote:

The numebr of views of this discussion suggests that more thna 2 people have this problem…

That’s funny…   This thread is just the announcement of the Firmware Release.   It has nothing to do with your specific issue.

Hi guys,

same prob here.

Also had contact with WD Support, following you can find the answer:


Do not place other file on the USB stick are safe for the unpacked file. Otherwise it can be very good that the update will not finished !

I  assume it have something with the hardware to do.

best regards


obleix wrote:

The numebr of views of this discussion suggests that more thna 2 people have this problem…


Anyway I’m in contact with the WD support and, if necessary, we will arrange for an RMA.

I am viewing this thread just out of interest. I don’t even have the unit!!