New Firmware Release - Version 1.01.10 for WD Elements Play (10/27/10)

WD is happy to announce our latest firmware update for the WD Elements Play. For information about the firmware, please visit the WD Elements Play Firmware Download  page.


Lets hope this sorts the problems out. Big thanks WD for providing an update for WDEP at last. Thats a thanks in advance, i’ll let you know if it actually works once I have tested it  :slight_smile:

so…does it work??

I’ve downloaded this firmware on 3 different computers (2 PC’s and a MAC) from 2 different locations.


So much for new firmware, who knows if wd fixed issues.


Thanks for the update WD.

But still no 1080p@24p support :frowning:

Hope you can resolve this issue!


Hey  crispao

did you get this firmware installed — how?

I tried from both the HDD and a USB stick, both failed after about 10 seconds.

Please tell me your secret.

now SubVOb play ok. but i see more lag on movies and more slow in the menu

I’ve installed it…but how can I put thumbnails for the videos? I’ve tried to paste the images with the same name of their video, but I can’t see them when I browse videos

My guess is it only shows cover art if it’s imedded in the image (like an MP4 tag).    Hard to tell, because the documentation doesn’t say it supports external “Thumbnails.”

I also own the 2TB version of WD Elements Play

I downloaded the file, unpacked it and copied the

cabin.img to a USB stick.

When I plug it to the WD E-P I can see my USB-stick, I see the file but noting happens!

What do I have to do that the player recognizes the file as a firmware update?

Or can I manually execute the firmare update?



What version is currently running on the EP?

got it…

my old USB stick didn’t work.

Found a newer one and tried with it - the WD drive directly asks for the firmware upgrade.

I hope the glitches in DVD-VOB files are gone now!

Apart from this…great player!

toodee wrote:


I hope the glitches in DVD-VOB files are gone now!

Please let us know.

Hi Tony,

I can’t seem to get this firmware upgrade to work at all.

The firmware is recognized and I do get the  option to perform the upgrade but it FAILS after 10 seconds with a warning message telling me the upgrade failed.

I have the 2TB version, I’ve tried the following:

  • reformat the drive using the WDEP option

  • reformat the drive using Windows 7

  • different USB sticks

  • firmware directly on (my empty - newly formatted) the WDEP HDD

  • different HDMI cables.

result is always a failure after 10 seconds…

my model is  WDBACC0020HBK

Once again, I’d appreciate your help

Download+Install worked as designed. To those with problems: did you read the instructions and unzip the file? (Just an idea…).

But MY problem persists: Videos with AC3 sound are mute (tried 1 channel Center and 2 Channel L+R, did not try 5.1 sound). Example:

ID                               : 1
Format                           : AC-3
Format/Info                      : Audio Coding 3
Mode extension                   : CM (complete main)
Codec ID                         : 2000
Duration                         : 43mn 28s
Bit rate mode                    : Constant
Bit rate                         : 192 Kbps
Channel(s)                       : 2 channels
Channel positions                : Front: L R
Sampling rate                    : 48.0 KHz
Bit depth                        : 16 bits
Stream size                      : 59.7 MiB (9%)
Alignment                        : Split accross interleaves
Interleave, duration             : 40 ms (1.00 video frame)
Interleave, preload duration     : 500 ms

Hi ,

I have the same problem. Don’t get the firmware upgrade installed. If I stick the USB in the WD Player, it found the new version, but it interrupt after five to ten seconds with a failure. I have the 2 TB version !!! Help is really appreciated…

regards Serkan

OK; got the new firmware installed after a bit of fannying about - I would advise just persevering. Once installed, the box rebooted and was up and running.  

The first thing I noticed was they have tidied up the settings button by grouping the settings together by type. You can now choose thumbnail mode for videos as well as list mode.  Only problem is that the EP still doesn’t pick up the jpegs  (with the same name as the video file) and use them as the icon for the video file (a la WDTV live).  I have a few MP4s with embedded thumbnails (from iTunes) but they didn’t seem to display either.  I will try a more scientific examination of this


There is a folder directory (on/off) option - not sure what this does yet.

DVD .iso files played fine, with full menu navigation.  I have mostly MKV files with AC3 soundtracks (created by Handbrake) and they all played through the TV without a hitch. Haven’t yet tested 5.1 sound via optical through my receiver.

So we’re nearly there; if only the box picked up the jpegs… 

1 Like

OK Guys,

I give in, what do you have to do to get this firmware installed…

I have tried the suggested installation so please do tell me to do the same thing again.

Please respond if you had the same problem as me (read my prior posts) and have fixed it.


ecciethetechie:  What version is CURRENTLY on your EP?

The original one, can’t remember the version number… not at home right now… but since the one I’m trying to put on is the only other one (am i wrong about that?) I don’t understand the reason for the question.

From what I understand there are there are 2 firmware versions.

  1. the original one

  2. the new one.

I’m still on the original one.