Network Connectivity Issues

I signed up just to post this…

I made the mistake of upgrading to the latest firmware - 2.02.32.

At first, I couldn’t connect to my NAS. A reset of the box, reentered my credentials, and all worked again.

Then the wireless network started flaking out - it would work for 3 days, then I couldn’t connect. A reset worked the first time, but last night it happened again. This time, a reset isn’t resolving the network issues. To be clear, I shouldn’t need to reset the device every three days.

I’m really annoyed. I’ve spent several hours trying to resolve these issues, and there’s been very little from WD about this. We have a second TV that I was just about to get a second device for, but I’ve decided against it.

Poor development, poor testing, poor customer service - the trifecta of **bleep**.


Sorry to know that you are having issues with your WDTV. I recommend you try to roll back the firmware to the previous version to see if the issue persists.

How to roll back the firmware on a WD TV Live Hub Media Center, WD TV Live Streaming Media Player, or WD TV Media Player