Netflix Canada magically working?

Through what I can only assume is voodoo, I was able to activate my Live Hub with Netflix.ca last night.  Anyone else tried this recently and have it work?  Since there was no firmware update, I have to assume it was on the part of Netflix.

Side note: No this is not an April Fools joke.  I watched an episode of Top Gear on it last night.

1 Like

How did you manage to activate it? the system asks you to activate it through Netflix.com and the dns request automatically routes you to the canadian page and there’s no activation link there?

I went to netflix.ca, logged in, went to Your Account & Help, and there’s a link to “Activate a Netflix ready device”.

holy ■■■■!! it does work! Netflix Canada is now supported on WD TV Live hub ladies and gentlemen! Although the A/V quality seems so so, I will give it a try! Thanks Captain!

As regards to video quality, it may be due to this.

http://blog.netflix.com/2011/03/netflix-lowers-data-usage-by-23-for.html

Thanks for the comment, I noticed that there were adjustable settings, and modified accordingly yesterday. It does improve a little but there is serious color blur and artifacts on my 60" 1080p plasma… I also found that audio quality was not what i expected (not all 5.1 content) I will continue testing for the next month.

I can confirm it works for me as well… where did you find adjustable settings?  I have a 50" Plasma and the movies look pretty terrible, even if they are tagged as being ‘HD’.

livehubber wrote:

I can confirm it works for me as well… where did you find adjustable settings?  I have a 50" Plasma and the movies look pretty terrible, even if they are tagged as being ‘HD’.

I would assume that you have to log into your account with a PC and upgrade the settings from there.

1 Like

Just logged back in to say just that… the settings are on the PC side.  Upped it to ‘Best’, but haven’t tried it out yet to see if there’s any difference.

I had a look… Video quality is much much better when choosing the ‘Best’ option in Netflix.  The lowest (new default) setting is unwatchable, in my opinion.

is this a joke?

I just connected my WD TV Hub today, and went to netflix, but tells me it’s unavailable, even though i can watch on my xbox, ipad, etc.

I am in Toronto, Canada

A few days ago it was giving me an activation code.  So I renewed my Netflix subscription, and I’m getting the error again.

Argh!!!

matthewe wrote:

is this a joke?

 

I just connected my WD TV Hub today, and went to netflix, but tells me it’s unavailable, even though i can watch on my xbox, ipad, etc.

 

I am in Toronto, Canada

I am just outside of Toronto and Netflix has been working fine since it magically seemed to work for us Canadians at the start of April.  I just watched Iron Man 2 a few hours ago in HD; it looked and sounded great.  I really wish there was subtitle support though… I know that’s a whole other issue that has been talked about at length elsewhere around here.  I noticed from the few Foreign film selections that I sampled that many seem to have hardcoded subs at least…

Not sure what to do about trying to get it going on your Hub, maybe try a system restart to see if it corrects the problem?  All that I did was navigate to Netflix, put in my code and it launched without any hiccups…

Ran back to my TV after seeing this message and it still works good. you should all get an activation code that needs to be entered on the PC side on Netflix.ca

I tried again, and no go.

I reset my device.

Changed the DNS on my modem to that of my current ISP Rogers, instead of openDNS.

Still cannot activate my hub with Netflix. What ISP are you using?

matthewe wrote:
I tried again, and no go.

I reset my device.

Changed the DNS on my modem to that of my current ISP Rogers, instead of openDNS.

Still cannot activate my hub with Netflix. What ISP are you using?

I’m using Rogers as well.

I’m on Bell

I think the problem must be with the Netflix activation servers.  If you got your activation code last week, then you can still use Netflix.  But they aren’t giving out any more activation codes right now.  I have a WDTV Live Hub and a Live Plus, and neither of them will give me an activation code.  I am on Telus.

The message on the screen says 'Sorry, this device cannot be activated.  Please visit netflix.com/tvhelp for assistance."

Sorry, guys.  It turned out to be a bug with Netflix.  Once someone posted about on their boards, they fixed it. 

I just tried again, and it’s still not fixed. Or do you mean the fact that it ever worked was a bug?

@bill_s,

can you provide the link to the Netflix forums please?