Need help with network issues

Hello,

I just got a MyCloud 3TB that I got working yesterday. It’s for an office with many different computers and people(10 or so).
I have access to a few different computers(win10 and win8) while doing this. I want to map the Public folder to a drive on the computer but somehow it only works when connected with Ethernet.

On one computer I mapped it while I was connected Ethernet then the computer messed up and now the ip is strange and the network is “unidentified”. So I tried on a second computer, the same model and both win8. It also worked great. It only works with Ethernet though and not wifi.
On Another computer that is win10 it doesn’t work at all. I can find the WDMyCloud in the Explorer but it doesn’t show up when I want to map it.

All computers can access the MyCloud in the browser, both as admin and as personal users. It’s with the lokal network that things are wonky and inconsistent.

What is it that I have to do? I have followed the “How to map a MyCloud…” but that doesn’t give any troubleshooting info. Is there a better Place to ask for aid?
I’m very thankful for any help!

Have you tried this using File Explorer? Right click on a Share and then Map It. See example image below.

image

If you have WD Quick View click on it and Map the Share. See example image below.

image

There are several ways to map it and my Desktops and Laptops have always been connected by WiFi.

On my Windows 10 PCs that I have now to Map a Share from the My Cloud (Public) I would choose This PC> Map Network Drive, follow the instructions being sure to check the block next to Reconnect at sign- in.

If one is having problems with only the WiFi PC’s not being able to access the My Cloud, check the WiFi settings in the WiFi router/AP and ensure the WiFi clients are on the same IP address subnet range as the wired computers. Also ensure there isn’t some sort of WiFi isolation going on (or a guest network) that are typically configured to prevent access to the wired side of the network.

There has been a recent change in Windows 10 where a recent update may disable SMB1.0 due to a number of security vulnerabilities in that protocol (see this Microsoft Blog posting). When this happens one may not find the My Cloud in Windows File Explorer. Often one can still access the My Cloud by inputting the My Cloud IP address (example: \\192.18.1.10) into the Windows File Explorer address bar. The following WD Knowledgebase article explains how to reenable SMB1.0 in Windows 10.

The problem is that on wifi the MyCloud doesn’t show up at all, so I can’t map it.

That is what I was thinking but when I go on to the router settings I have no idea what I might change. Something blocks the MyCloud on the WiFi and I don’t know what I’m looking for.
Do you have any ideas? I will try the Win10 fix later but as of know I’m looking at a Win8.

What Bennor told you could be the problem in both Windows 8 and 10, will not hurt to look and see. Open your Control Panel>Programs>Turn Windows features on or off.
See example image below. Click on, tap or activate image to enlarge it.

Like I said, I’m on Windows 8 so I can only see the SMB 1.0/CIFS File Sharing Support and no features under it. It is and was activated though so that can’t be it.
I will still check for it on the other pc’s.

Any other ideas?
I’m very grateful!

To check the WiFi one would need to access the local network WiFi router and review the various WiFi settings. If WiFi users are connecting to a “guest” WiFi network that could be one problem. Sometimes there is an option called IP Isolation or something similar. It is an option that separates the WiFi clients from the wired network clients. One should also check the IP addresses of the WiFi clients and ensure they are in the same IP address subnet as the My Cloud.

I don’t use a “guest” WiFi but this WiFi is from a router which in turn is connected to a modem in another building with a separate WiFi.

Make sure they are on the same subnet?
I just checked my ip on this computer and it is .2.59 while the MyCloud is on .1.114. Is this what you mean?
How do I go about changing this?

Yes that is what I mean, it appears the computer and My Cloud are on different IP subnets which could/often leads to problems accessing the My Cloud.

To change it one has several options. First is to access the administration page of the router that is hosting the DHCP server or that his controlling the WiFi and configure the WiFi clients to use IP addresses in the same range as the My Cloud. Or one could configure each WiFi client with a static IP in the same IP address range as the My Cloud. Or one might be able, depending on the WiFi router settings, to configure the router to pass traffic between the two different IP address subnets.

Bottom line is this is a network issue not a My Cloud issue. Generally it will require you to access the router’s administration page and check the WiFi and DHCP server settings and possibly reconfigure them so both the WiFi clients and the wired LAN clients are on the same IP address subnet.

I don’t know if this is beyond your knowledge but I get the feeling that it isn’t.
If I were to change this from 192.168.2.1 to 192.168.1.1 would I mess up the entire network “infrastructure” or would it adapt?
Seeing as the MyCloud is on 192.168.1.114.

Changing the IP on the different computers to Static doesn’t feel secure since the majority are laptops and are up and running from time to time. As I see it that would be an issue, would it not?

xcv

Again, I very much appreciate all the help!

Lets step back for a moment and examine what is connected to what on your local network. Is the My Cloud connected to the same (what I assume is an) Asus router as the wireless clients? If so they should all be using an IP address within the 192.18.2.x range. Unless the settings on the DHCP Server tab are different and there is a different IP Pool Starting Address and Ending Address range. Are there more than one router connected to the same local network?

Generally it is advisable to set certain devices (like the My Cloud) to use a fixed or static IP address. This is because each time the My Cloud is restarted (or started) or if the router is rebooted or restarted the My Cloud may end up with a different IP address which may impact access like mapped drives and remote access to the My Cloud. Using a fixed/static IP address for the My Cloud means the My Cloud uses the exact same IP address every time.

And under Wireless > Professional on the Asus router, is Set AP Isolation set to Yes or No?

Set AP is on No.

The only router goes to a switch where all wired things connect and it then all devices which uses WiFi connects directly to the router.
The LAN ip adress is as I showed you, 192.168.2.1 with a Pool Starting Address of 192.168.2.2 to 192.168.2.254. However, all devices connected with Cable has 192.168.1.x while all using WiFi are 192.168.2.x.

So in any case I definitely want to make the MyCloud IP Static.

How are the wired devices obtaining the 192.168.1.x IP address? From the same router that is handling the WiFi? Why is the WiFi network using a separate/different IP subnet?

The problem you face is that by changing only the My Cloud IP address you may cause wired/cabled devices not to be able to access the My Cloud. Ideally all devices on the local subnet would be in the same IP address range (example: 192.168.2.x).

This sounds like a routing related issue. Can you ping in both directions? (From wired side to wireless side, and vice-versa?) If you cannot ping across the different subnets, then there is no route between the subnets, and that is your issue.

So I ping from one device connected to WiFi and then ping from one device using cable? Or what do you mean? And when I do that, do I just write “ping” and then the IP on the device?

Say you know the IP addresses of a device in each of the subnets.

From the X.X.1.X subet, you ping that known IP in the X.X.2.X subnet, and see if you get a response.

eg,

ping 192.168.2.25

You will know almost right away if you are getting responses, as the device should respond to the ping requests with a response time in ms. Something like this:

(this is me pinging my own mycloud, just to demonstrate what it looks like.)

ping 192.168.0.129

Pinging 192.168.0.129 with 32 bytes of data:
Reply from 192.168.0.129: bytes=32 time=1ms TTL=64
Reply from 192.168.0.129: bytes=32 time=3ms TTL=64
Reply from 192.168.0.129: bytes=32 time=1ms TTL=64
Reply from 192.168.0.129: bytes=32 time=3ms TTL=64

Ping statistics for 192.168.0.129:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds
Minimum = 1ms, Maximum = 3ms, Average = 2ms

If your device is not reachable, it will instead say “CONNECTION TIMED OUT” and have 100% packet loss.

Do this in both directions. From 192.168.1.X -> 192.168.2.X and vice-versa. You can do the pinging from any machine in the two subnets that you have access to.

I have no idea at all why that is and until yesterday I didn’t know that was the case.
Like you say, i can’t just change the IP on the MyCloud since then either WiFi or cable wouldn’t reach it.

So the real question, what can I do here? From what I can see on the router settings the LAN IP should be 192.168.2.1. However like I said, that is only the case for WiFi and not for cable which is on 192.168.1.1

From what I can understand there is no benefit to having separate WiFi and ethernet IP, only issues.

What if I were to change the IP on the router to 192.168.1.1 to maybe get the WiFi over to 1.1 instead of 2.1? Or would that just mess things up?

I am not at the location right now but I will definitely try that as soon as I can!

What you need is a route between the subnets.

There is a reason you need to check in both directions. Both subnets’ routing tables need to have valid routes to get from their subnet to the other, and situations where data can only travel one direction are entirely possible.

This is the job a router provides. It has two network interfaces. One lives in one subnet, and one lives in the other. When a packet is destined for the “Foreign” subnet, the computer checks its routing table, and sees if there is a route defined for that subnet. If so, there will be an entry that says “Send it to this IP address”. That IP is the one the router uses. The router accepts the packet, reads the header and sees that it is destined for that other subnet. If it has an interface in that subnet, it will forward the packet.

Often, to prevent public users from gaining access to privileged hardware on a wired network, a location will PURPOSEFULLY segregate the subnets, and PURPOSEFULLY not define routes between them. This keeps annoying snot nosed kids in the lobby from sending pornographic print jobs to the printer in HR, among other things.

If your mycloud had more than one gigabit ethernet port, then I would suggest setting it with two IP addresses-- one in each subnet, and attaching it accordingly. Sadly, the single bay units do not have more than one physical interface, making that impossible. IIRC, the EX2 and pals do have more than one ethernet interface.

Investigate if there is a lack of valid route between the subnets-- then ask the site’s NOC if this is purposeful, and to advise.