Need help on how to mount shared My Book Live folder to Synology NAS

I’m using the Plex server on my Synology 918+ NAS and have all my music files stored on a My Book Live external drive. I dont want to actually move them to the NAS but rather allow the NAS to access the My Book Live.
With help from a Plex user, I created a shared folder on the NAS and named it “Music” and then went to that shared folder, tools and then selected “Mount Remote Folder”. It gives me the option to select CIFS or NFS. From what I was told CIFS is the way to go so selected that one and entered the route to my shared folder on the My Book Live, the username and password used on the My Book Live, and it automatically filled in the location on the NAS where I wanted to place the mounted folder.
I repeatedly get the error message that it cannot connect and add the folder. The Plex user asked if I have given the My Book Live permissions for the NAS access it…have no clue how to do that. I can get to the shared folder on the My Book Live using the exact same path in a browser so have not sure if the permission thing is what is causing it not to add the mounted folder.
Any help/guidance on how to get this working would be greatly appreciated!!

No, you need to provide the username and password for the account you set to have access to the shared folder on your My Book Live.

If you didn’t set the permissions, then by default, it’s a “Public” folder and you don’t need to provide any userid or password to connect.

Exactly what did you enter?

The route entered to mount the shared folder on the My Book Live to the NAS was like, // Music

This is using the CIFS method

you might need to set the version to 1.0.

If memory serves, in your fstab the line is something like:
//\040TV /media/shared_tv cifs vers=1.0,username=pi,password=Sekrit,iocharset=utf8,sec=ntlm 0 0

Are you saying to put that whole string in you mentioned as the path to the shared folder I want to mount on the NAS??

Sorry, I was in a rush this morning. Assuming your Synology is running a Linux similar to mine add this line to /etc/fstab

//backup/Music /mnt/Music cifs credentials=/home/pi/.credentials,iocharset=utf8,sec=ntlm,dom=Mordor,vers=1.0,soft,uid=1001,gid=1000 0 0

Change the ‘pi’ in /home/pi/.credentials to whatever name you’re using. I’ll keep using pi. Change the domain (Mordor) to your workgroup/domain/SSID. Change the uid and gid as needed, or delete them. Oh yeah, that line above is 1 line.

Create /home/pi/.credentials and put this into it:


Sekrit is pi’s password on the My Book Live.

Now chmod 600 .credentials.

I think that’s it.

Wish I could edit my replies. sigh

Use // instead of //backup/Music. Capitalization is important when discussing paths and files, not so much for networks. Get into the habit of using the same Capitalization everywhere.

Everything from //backup/… to …gid=1000 0 0 is all 1 line in /etc/fstab.

Ensure you mkdir /mnt/Music, and chmod 755 /mnt/Music.

mount -a should now mount the shared folder.

Sorry for not fully understanding since I’m certainly not a wiz at this stuff! This is what I’m going off of to mount the My Book Live to the NAS:

So I"m not fully understanding what you mean by /etc/fstab, etc

The problem is you need to set vers=1.0 for the My Book. I’m not seeing in their GUI how to do that.

I’d try an nfs mount. Can’t hurt, and it might work.

If that doesn’t work ask some of the neighborhood kids to see if they know Linux and can set you up :slight_smile: Or hire a pro.

I don’t have a Synology, I’m just assuming it runs some form of Linux.

You might try the Synology support, tell them you need to access the My Book Live share with cifs version 1.0, and ask how you do that in their GUI.

One more thing. If you don’t know what Linux nor /etc/fstab is then don’t try to do this yourself. You’ll most likely brick your Synology and have to pay someone like me lots of money to get it back, if indeed I can get it back.

Learning Linux is fun and rewarding, but your Synology is not the place to learn.

Yeah already reached out to Western Digital to see how to set up cifs since I dont see anything on their admin dashboard for it. They Synology folks are basically saying “enable cifs or nfs on the My Book Live”…yeah, if I could figure it out!!

Trying to do it via NFS gives me the same result

The problem lies with Western Digital using an ancient version of cifs, but unless you can get them to release new firmware (unlikely) you have to deal with the problem where it pops up. Which for you is the Synology.