Xmount my book live


#1

Can i xmount my book live to use with wdlxtv. I try to xmount with nfs but it dont work. I get the message : permission denied. Somebody know how die xmount my book live for wdlxtv? Sorry for my english, i’m from austria.


#2

The My Book Live does not support NFS.


#3

Thanks for your answer. Do you know what i can use to mount it?


#4

If nothing else, just use the regular SMB-based sharing; the “Network Shares” function.

WDLXTV has some way of pre-defining those shares so that they look like directly-attached storage, but I’m not sure how that works.   My recollection is that you have to put some sort of file on a USB drive for the WDTV to read and mount those shares.


#5

Ok, there is no way to get moviesheets work on MyBook Live. I try to mount it with ftp server of MBL, also dont work. Ich hope nfs share will come in next firmware, or moviesheets in next wd tv live firm.


#6

Well. I do have a WD TV Live as well - running latest wdlxtv and using NFS to share media with the WD MyBook Live and use MovieSheets.

The only point is, that you need ssh access in the first place and install / setup the NFS - Server properly.

Then just mount the shares to the wdlxtv (xmount) with USB stick present and everything is working fine. (Access via local media then.)

Regards


#7

Thanks for your answer, but i dont understand how to install and setup nfs on my book live. The Wdlxtv has nfs, i know. I read a lot of nfs share on wdlxtv, but i dont know how to get it work on my book live. Can you write me a How To for this. I hope i can do work moviesheets on the my book. It looks great on my other usb-drive. Thanks


#8

First enable ssh! Look up how to do it in this forum.

Next I have the feeling that the NFS Server is not setup properly so I would reinstall it first.

just use

apt-get install nfs-kernel-server nfs-common portmap

next edit / define the exports. That is done in the file /etc/exports.

Maybe you con at first look into that file and test if the NFS-Server is working properly.

so

nano /etc/exports

Then update / insert the directory and the target to export

/DataVolume/shares/xxx ip_adress of the wdlxtv

or instead of ip_adress use for instance 192.168.1.1/24 for the whole network from 192.168.1.1 to 192.168.1.255 at netmask 255.255.255.0 if you like to use the shares otherwise as well.

Then restart the server

/etc/init.d/nfs-kernel-server restart

On the wdlxtv use the xmount in the net.mounts file as researched allready.

Good look.


#9

Thank you, i will try it now.

Only part i dont understan good:

Then update / insert the directory and the target to export

/DataVolume/shares/xxx (ip_adress of the wdlxtv thats OK)


#10

Suppose you have a folder you want to share called “Media”. Generally your data is stored in a folder (started from root) /Data Volume/shares/… something… on the MB Live. The WD TV Live is on IP 192.168.1.150.

The full path to that folder is then /DataVolume/shares/Media/ (the Public Folder by the way is /DataVolume/shares/Public/ etc.

edit the /etc/exports - file:

The syntax of NFS shares is: shares_folder target_client(OPTIONS)

So in our example: /DataVolume/shares/Media 192.168.1.150(ro)

There are several other options, even the read only (ro) can be omited - there are some default options used instead (ro is default too).

After restarting the NFS server there might some complains about missing Options, but defaults are used.

Hope that clarifies it somewhat.


#11

Thank you, you write it very simple. I understand it. I will try it today.

Edit:

My Steps ->

1.ssh with putty

  1. apt-get install nfs-kernel-server nfs-common portmap

  2. nano /etc/exports

  3. ??? (I have one Folder for Share on my NAS its “Film”  My NAS is Y, so I need    /Y/Film 192.168.1.50(ro), i dont know where i put this command, if i write it after step 3, nothing happens) If i go to exit after step 3, and write it then i get a error.

Ther are command like this after step 3:

/nfs *(rw,all_squash,sync,no_subtree_check,insecure,anonuid=99,anongid=1000)

^G Get Help  ^O WriteOut  ^R Read File ^Y Prev Page ^K Cut Text  ^C Cur Pos
^X Exit      ^J Justify   ^W Where Is  ^V Next Page ^U UnCut Text^T To Spell

putty2.jpg

I think linux and ssh is only for experts.

Thank you for your HOWTO.


#12

OK. First point. The MyBook Live uses a Debian Linux - drive letters are more Windows-style. Linux is basically looking on each and everything as a file - even devices. Then every thing is structured like a tree - starting point - guess: “root” or “/”.

Second. As there are no drive letters your folder will be created (via the web-end of the MyBook) in the folder /DataVolumes/shares/. So now it depends where you created this folder - within Public?

The easiest way to figure out is - again - via ssh. Just log in and the type:

cd /DataVolumes/shares/

ls

Search any of the listed folders below for your folder “Film”.

(There should be at least another folder named “Public”.)

You are right, in the file /etc/exports is currently one entry referring to the folder /nfs.

You can either leave it as it is, or commenting this out - just insert # in front of the line.

Next step as already mentioned in earlier posts -> edit /ect/exports

Basically you can even copy paste my lines there and add just your folder “Film” at the end (depending where the folder is located at your system)


#13

Thank you very much !

Everything was OK . :smiley:

Now i must do the settings on WDLXTV.( I will tell you when have the moviesheets running)

Edit:  Perfekt !!!   :smileyvery-happy:  Thanks