MYPASSPORT router doesn't see Ethernet port on network router

Hello all.

This may be a Windows networking issue, but it is directly related accessing the MYPASSPORT drive, and I think, the MYPASSPORT router.

MYPASSPORT is connected to my local network router for Internet access. I have a WDMYCLOUD connected to a router Ethernet port. I normally connect my laptop to the 5GHZ router network. Windows File Explorer displays both drives ([\MYPASSPORT](file:///\MYPASSPORT) and [\WDMYCLOUD](file:///\WDMYCLOUD)). I can access either drive by clicking its link. If I connect my laptop directly a MYPASSPORT network, file explorer no longer shows WDMYCLOUD. I can’t access the NAS. See image.

This affects my auto backup app which can’t access the storage folder on the NAS.

Does anyone know why Windows can see MYPASSPORT when connected to the network router, but can’t see the NAS when connected to the MYPASSPORT router? Is this a limitation of the MYPASSPORT router? The MYPASSPORT router is definitely passing data through the network router to the Internet. It sees a USB port on the router (RT-AC68U), but not the Ethernet connection. Any way to fix this?

Thanks for any help.


Hi @sailguam,

This is to inform you that we are unable to check error message.

Please refer below link to help you with trouble shooting steps:

Hi Keert,

Thanks for the response. Are you talking about error message I tried to send from the dashboard.? I have 2 drives. The first one is defective, I hung at 45% every time I tried to run diagnostics, I have a 2nd drive which is working fine, but I can’t connect to a WDMYCLOUD NAS when connected to the drive.

The drive is working fine. The question is how to map the NAS so MYPASSPORT will connect to it via the network router. I sent this question to support, but if anyone here knows how to fix this, I would appreciate hearing.

I have the wireless MYPASSPORT Pro connected to m ASUS network router 5GHZ network for internet access. I have a WDMYCLOUD 4TB NAS connected to an Ethernet port and a WD portable MyPassport HDD connected to a USB port on the router.

I need to transfer data between the wireless drive and the NAS. If I connect my laptop to the router, I can see the wireless MyPassport, but the transfer rate is very slow. If I connect directly to the wireless drive, I can see the wireless drive, the internet and the USB drive connected to the router, but I can’t see the NAS.

I tried mapping the MyCloud NAS ([\](file:///\\WDMYCLOUD), but Windows can’t see it. I also tried adding \sharename, but sill could not connect. The MyPassport drive is connecting to the router since I get internet and the USB drive, but it doesn’t see the Ethernet ports.

Any idea how to fix this?