Windows Explorer Can't See MyPassport Wireles Pro

Windows Explorer can’t see MyPassport wireless HD after a power outage and router reset.

I have a wireless MyPassport and a wired MyCloud connected to my WiFi router (ASUS RT-AC68U). All devices were accessible in Windows Explorer under “Network”. After a recent power outage and router reset,
everything is normal except that MyPassport no longer appears in Explorer.

If I connect my laptop to MyPassport, instead of to the router network, MyPassport appears in Explorer instead of the router, but I can no longer see MyCloud. I can access the Internet via MyPassport > router.

All the devices still appear in the router client list as before. I have SMB 1.0/CFIS Client checked in Turn On/Off Windows features. Everything worked fine before the power outage.




Update. Windows Explorer is seeing MyPassport after rebooting my router. I should have thought of this first. I have another question. Should MyPassport automatically reconnect to the router after a power outage?

I have been using MyPassport for a few years and I believe it was automatically reconnecting to my router after power outages. We are currently having a lot of power outages now and each time, MyPassport disconnects from my router. I have to connect to MyPassport and use the browser on my laptop to reconnect MyPassport to the router.

The MyPassport dashboard says if I forget the network, MyPassport will no longer automatically reconnect, which suggests it should reconnect after a power outage. I don’t see any option to automatically reconnect. I don’t see this I the user manual.

Appreciate any advice.



Hi @sailguam,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Hi Kerti,

Thanks for the response. I purchased the MPWP in 2021, not sure WD will provide support. I was trying to trouble shoot first, but I will open a ticket. I did a factory system-only reset. Everything seems to be getting back to normal, except not reconnecting to router after power outage,



If anyone is following or has similar problem, I sorta solved it. I tried a system only reset from the dashboard. The reset froze and I could no longer connect to the drive. I was not even asked for key. I disconnected the power supply and reset by holding down the power and wps buttons. I was then able to set up the MyPassport like a new on. Everything works, except the dashboard doesn’t show capacity and usage. I am going to leave it there for fear of breaking something.