MyPassport 0748 Connection Issue, Possible Crash?

Portable MyPassport was working today but was making a lot of beeping noises. When trying to access it became very slow. When trying to eject through Windows7 it failed, when tried again after closing absolutely everything it failed. Windows Explorer crashed as well. When trying to shut down it resulted in a seemingly never ending shut down teal screen with the MyPassport going between states of flashing, staying solid and was beeping from time to time. I tried another Win7 computer which gave the hard drive a letter but could not access it, windows explorer would crash if tried to open up the Local Disk assigned to MyPassport. Windows Disk manager failed to load while MyPassport was connected. Tried connecting it to a Win8RT tablet which resulted in it coming up with the message saying USB device not recognized, tried unplugging it a couple times. Tried connected to an old WinXP machine, it did not recognize the Passport or the MyBook(that has worked on all other machines) but the MyPassport would cycle through states of flashing and being solid, while the MyBook would remain in one state. Currently have MyPassport attached to the original computer that recognized it. It is assigned the drive letter E and is only recognized as a Local Disk in Windows Explorer, MyPassport 0748 in Devices and Printers, and WD SES Device in Device Manager. The drive itself is solid white and is beeping occasionally, not in any pattern really.

tl;dr MyPassport is being assigned drive letter, but cannot access data on drive, crashes windows explorer, tested on multiple machines.

Hello,

Are you able to try the unit with a different USB Cable?

If stills the same, try testing the drive using the WD DLG tool.

Link to app: http://support.wdc.com/KnowledgeBase/answer.aspx?ID=940