Mypassport 0748 - no password prompt / can't access


I have a MyPassport 0748, which I can access on my laptop. It shows as a virtual CD drive and prompts me to enter my password, and once entered gives full access to the device. Normal so far.

When I try to load it on my desktop, it sometimes shows the virtual CD, sometimes shows local disk, and sometimes doesn’t show up at all. It always shows in device manager under Disk Drives. When I click on Virtual CD or Local Disk, it doesn’t prompt me for my password. It just says the folder is empty.

How can I get this to work on my desktop? Both computers are Windows 10 BTW.

Thanks in advance!

Are you connecting through a hub on the desktop? If so, try connecting directly. It also sounds like the Passport may not be getting enough power. Try a different port.

Thanks, I am connected directly to the machine, and have tried different ports. I will try a couple others just to be sure.

Are you making sure to use the USB cable the came with the drive?

I am. Good news, I had tried 3 of 4 ports and didn’t think that would make a difference. 4th port, and it worked. Strange, but appreciate your help!

The issue may actually be that there is not enough power coming out of the other ports. That’s why I was asking about the USB hub and cable length. Nowadays, they are making at least one of the ports with more amp output than the others. I just bought a new laptop and that came as a feature.